Ring 2 recordings are all blank, but snapshot recordings are fine

One of the Ring 2 doorbell units is showing motion events, but has now been recording blank videos, where the video is all black screen. This would seem like a failure of the camera, except the periodic snapshots recorded show up perfectly fine in the timeline. This has been happening for months now apparently, and I can only rely on the snapshots to see anything from this unit, as even the live view is nothing but a black screen.
Is this a common issue? I’ve got three others on the same account and they’re working as they should.
Is there different hardware involved between video recording vs still recordings for snapshots? Is this unit now defective?

1 Like

this has been happening to my Ring 2 for weeks and I cannot get an answer from Ring.
An overnight incident occurred and police were requesting video images. I confidently offered my videos only to find that I either have a black screen OR a “No video found” message, I didn’t realise that this had been happening to overnight motion alerts for weeks. I am partially sighted and this is my security. Fine security when it doesn’t record overnight incidents.
Why is nobody from Ring addressing this issue???

I’ve just started having the same issue. First it was only in recordings but now it has happened during live view. The actual live view works at the time but if I go back and view it again later, it black.

Hey neighbors. Let’s see if we can get to the bottom of this. First, can you confirm if the videos are showing up in your Timeline, but not in your Event History? Second, try rebooting your internet router, then attempting Live View from the Ring app and Rapid Ring. Additionally, this Help Center article here has some steps for correcting Live View. Let me know if this helps!

1 Like

The events site up in the list and the time line, but any attempts to view the recordings only shows black screen video. Snap shots in my case show up normally as I scrub in the time line view, which is the only visibility I can get from the camera now.

I’m going to try giving the battery a full charge externally to see if the low battery is causing the issue, in case video recording requires more power than snapshots, and it thinks it’s recording when it’s not.

1 Like

Hi @Calle. Thanks for updating me. Let me know if charging your battery will affect the way this works. If it doesn’t, I’d suggest reaching out to our support team to take a closer look into this. Please give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.

1 Like

Tried restarting it after charging the battery, and it looked like it still showed a blank video one time in a live video recording, but has started showing video on the live view and recorded clips.

It hasn’t recorded any motion events yet though, because it seemed the trouble was tied in with it recording continuously in absence of motion, so I basically turned off the motion recordings to stop it. That may have been what ended up draining the battery.
I’m going to restore the motion recordings to see if they start working again.


Hey @Calle. This sounds promising, please keep us posted in the coming weeks.

1 Like

It does seem to have resolved after removal of the battery and restarting it after a charge, the clips are not blank when viewing.
If they cannot operate properly with the battery level low it should probably make it known to the user instead of continuing to operate but just recording blank video.

On another note, the 8006561918 Ring Customer service number rings once, then automatically disconnects. Is it set to do this when it’s off hours or if they’re otherwise not available?
Usually companies would play a recording indicating their office is closed or something, and tell you to call back, rather than abruptly hanging up after one Ring. Is this how it’s set up or is it a glitch?

Hi @Calle, chiming in for Tom here. I’m glad to hear that you’re successfully able to vie Live View and videos now. It’s possible that the reset involved in your troubleshooting steps is what resolved the issue itself.

For any other neighbors still experiencing this, please try removing and recharging your battery, and then performing a reset of your Ring Doorbell 2 with the fully charged battery inserted. You can reset your Doorbell by holding down the setup button for at least 20 seconds. After that’s done, set the Doorbell back up and test out the Live View.

In the meantime, please let us know if this concern happens again and if it coincides with a low battery level specifically. As for the support number not connecting you, around what time did you reach out? Did this happen only once or did you try calling the number again and did the same thing occur?

I’ve tried calling several days now, with the same result, one ring, then it disconnects automatically.
Calling from my cell phone, don’t know if that’s a factor or not.

1 Like

It was just my cell phone with an issue making calls; I just didn’t realize it because I guess I rarely need to call anyone nowadays. Restarted my phone and the call went through just fine-:slightly_smiling_face:

1 Like

@Calle Thanks for letting me know! I wanted to ensure there were no issues with our support number, so I’m glad it was only a temporary issue with your cell phone that was resolved with a restart. :slight_smile: