Repeatedly failing setup process due to wifi connection

I have today purchased a Ring doorbell 3. I have been through to setup process numerous times and every time it won’t connect to the WiFi at the end. I have a BT home hub 4 and I have tried various suggestions including separating the WiFi channels on my bt admin site, done a hard reset, reset the bt hub. The only thing I haven’t done is charged the battery to full which I am doing now. Is this the issue or is it something deep in my WiFi router settings? I’ve successfully managed to set up the ring chime without any issues.

Hi @Mikeclarkson96. Fully charging the battery is definitely one thing you want to do before attempting the setup process again. I would also suggest trying to walk through the setup on a different phone or tablet if you have one available. If you’re trying to connect the Doorbell to a 5.0GHz network, try using a 2.4GHz network instead to see if that works better. While the 5.0GHz network is faster, the 2.4GHz network is more reliable at longer distances and will still provide enough speed to support the Doorbell.

If the Doorbell is still not connecting after trying these steps, please give our support team a call at one of the numbers available here so they can take a further look with you. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.