Red dot on Ring App

Morning all,

How can you get rid of the permanent red dot on the top left corner of the Ring App. Checked the new feature part and all enabled.

1 Like

I have the same issue. I’m using the new features but red dot refuses to go ?

Hey neighbors! If you have a red dot at the top left of your main menu bar, and when you open it it has a red circle next to New Features, I may have a resolution that works for you. I too had a persistent red dot as well for New Features, and once I clicked on New Features I swore I read them all but it still said I had 2, so I went there and click on “View Feature” in blue until I returned and it was green. From there, I forced closed my app, and reopened. Then I still had the red dot, but it said 1 instead of 2. When I clicked on New Features, I did have a new feature there, which I then viewed, force closed my app again, and reopened the app. When I reopened the second time, it was gone!

Wanted to chime in since I just went through the same, and hope this helps you get rid of it as well. I will make sure to pass on this experience to the appropriate team for us all as well. :smiley_cat:

I have the same issue and it’s a complete pain everytime ring decides the force-feed you new features. I had the same problem last month with the timeline feature and in their infinite wisdom they hide all these ways to disable the features in various places, some that make no sense whatsoever. I truly believe they need to fire every programmer they have and hire some new ones! They don’t make it easier they just keep making it more difficult! If that’s the best you can do Ring, please quit improving your already horrible software!

I have the exact same problem. I’ve tried everything including all the recommended actions and nothing has worked.

1 Like

Did not help, nothing has helped?