Rapid Ring - Cannot sign in

I am running an older version of the Rapid Ring app on an old (IOS10) iPAD. I had reason to re-install the app (electing to redownload and install the latest ‘compatible’ version. I have since been unable to log in to the app. I get a failure and a message saying cannot log me in at this time.

The Full Ring app runs on the same iPad without any issues (apart from taking too long to load and so not being useful for dealing with notifications)

I can log into Ring using the same credentials. I have deleted and re-installed the App and restarted the iPAD but the issue remains.

Any help welcome!



Hi @johnbury. To clarify, have you installed the latest version of your tablet’s OS as well as the latest version of the Rapid Ring App? If your OS or the Rapid Ring App is not up-to-date, this is likely why you are receiving an error when you attempt to sign in. I’d suggest updating your tablet’s OS to the latest version and then installing the most recent version of the Rapid Ring App.

My iPad is as up to date as Apple will allow it to be (Bless Apple for their commitment to backward compatibility!). It runs IOS 10

I reinstalled the app from the appstore using the option ‘install latest version compatible with your device’ (Version 1.8.0).

The same iPad runs the full Ring app (5.29.1) and that works adequately.

the iPad is used solely as a monitor for my Ring Video Camera Pro and has worked since installation around 9-10 months ago.



@johnbury The latest version of iOS is going to be 13.6.1, so running an older version of this OS is going to cause compatibility issues with apps such as the Rapid Ring App. We’re not able to guarantee the performance of the Ring App or the Rapid Ring App on devices that are not running the latest version of their OS. To avoid any concerns with either app, I’d recommend using a device that can be updated with the latest OS. :slight_smile:

so the full Ring app is fine on my iPad, but (the appropriate, albeit old, version of )Rapid Ring isn’t?

Sorry i don’t get it!

It has worked for months, now doesn’t… please explain.



@johnbury We cannot guarantee that an outdated version of the Ring App, Rapid Ring App, or Neighbors App will work on any OS. Additionally, you may encounter issues with the performance of apps when using an older OS on your device.