Rapid Ring Audio Echo

I would like to use Rapid Ring on my iPhone 6s Plus but I have a problem that makes it unusable. When I open the app open on my phone to speak with someone at the door, everything I say is echoed back to me through my phones speaker. Support has been unable to resolve the problem, and it doesn’t happen on the standard app. Has anyone else experienced this issue and found a fix? Thanks in advance.

I have the same issue. My voice is echoed back to me at door. Did u find a fix?

I have tried everything and have not been able to find a fix. If you do please let me know, and I will do the same. Are you using the app successfully with the echo or did you give up like I did?

I’m about to give up. When I called customer service they tried, but were no help. Just curious do u have an Android or IPhone? I have the new Galaxy S10 and the newer androids seem to have issues bc they have dual microphones…

I have an iPhone. Customer service tried everything they could think of but no luck.

Thanks, I was wondering if it was phone. We have the ring elite, directly connected to router. Just trying to figure out if we have anything similar that might trigger as to why. I didn’t see any other posts saying they had the echoing issue.

I have the exact same problem. Support had no idea what to do. The support person tested it on his devices and reported fine. Interestingly I do not remember having this issue with my doorbell or doorbell 2. Now upgraded to doorbell pro rapid ring became useless due the echoing. I think it’s a bug in the app. I’ve noticed that the normal ring app cuts out your audio (mutes the doorbell mic or your phone speaker) while it’s playing your voice on the other side to the postman but the rapid ring just plays it back to you for some reason. Have to give up on rapid ring for now. Tested on my wife’s phone too. Same thing. Both iPhones.

Glad to know I’m not the only one. If u ever discover a fix, pls post. I can’t use Rapid Ring bc of this. Thanks for posting, maybe if enough post, they will dig deep enough to find out why the echoing is happening.

I don’t wish this problem on anybody, but I am happy to hear I’m not the only one with it. I’m disappointed that I can’t use Rapid Ring, but my only option now is to wait until someone finds a solution.

P. S.

I also have the Ring Pro and I’m trying to use Rapid Ring on an iPhone.

I went back today using the normal ring app and seems to work well. Almost as fast as rapid ring. When the notification came that someone rang my bell I tapped on the notification and it loaded the doorbell’s live view straight away. Did not need to navigate through menus or anything. Maybe because the app was open in the background? It was reasonably snappy. Took about 15 seconds from the doorbell press to me saying hello to the delivery man, based on the video when reviewing it after the event. Also you can talk to support and they can change the two way talk volume on your doorbell. I found out last night when tested the rapid ring issue. I have changed mine down to 8 (1-11 range) from the default max 11 and while the echo still present it’s at least clear not distorted. I’d say just stick with the normal ring app as it has no issues and for me was reasonably snappy too.


That’s good news. I haven’t tried leaving the standard app open in the background. I’ll give that a try to see if it speeds things up a bit!

I have had the same exact issue, been in touch with customer service, they couldn’t help me. Let me know you if find a resolve. I will follow this thread.