Rapid Ring App suddenly has "weak connection issues"

Did this ever get fixed? I have had 2/6 cameras failing to work with Rapid Ring for a while now (although they did work when Rapid Ring was originally launched).

RSSI is no issue but apparently the connection is too weak (which seems to be a false error). My best guess would be that RR perhaps just doesn’t work any more on mesh networks… but if we had a comprehensive list of ports then we might be able to debug…

AndyH

I am having the same problem. Rapid ring was working great. Now says weak connection. I’ve removed and reloaded the app and turned on and off my iPad. Regular ring app works fine but rapid ring was so much faster. I’m at a loss as to what to do now. Thanks.

Same here.
Using Android.

Interestingly don’t get this on the normal app and my RSSI is good.

Ring is terrible for WiFi. I can stream 4K Netflix at the end of my garden but it struggles with my Spotlight which is above the window where my router is.


Your Netflix isn’t having to go through an outside wall. Depending on what your walls are made of it can be very difficult for a WiFi signal to go through.

Any update here? I just started having this issue on (IoS)
deleted, rebooted, reinstalled… no avail

1 Like

I was able to correct this issue by removing the device and performing a new setup.

1 Like

Stopped working for me, normal ring app works fine. Rapid ring just won’t load up the feed, saying week connection issues. Never had a problem before. Try uninstalling, turning off phone and Then reinstalled but still not working!

2 Likes

same here
have ring rapid installed on two android and one IOS IPAD device,
worked fine on all 3 devices, now not working on any,
main ring app works just fine, its NOT a weak signal issue - as main app works just fine with excellent frame rate (the first indicator of poor wifi connection/speed)

tried to delete and then reinstall app, logged on ok, git verification msg - all good.

clearly ring are messing around

STOP IT STOP IT

we just want it to work reliably …

2 Likes

In another thread someone mentioned Ring support says that “Rapid Ring” app will be discontinued. @Chelsea_Ring can you or some other support tech confirm this? This just started happening a day or so ago.

Hey neighbors! If you’re experiencing any Live View or connectivity concerns with the Rapid Ring app, please try the following troubleshooting steps:

  • Check out our Community Post on Live View concerns specifically, which can help you narrow down what may be causing the Live View to not work.
  • Follow the best practices in our Help Center Article here to ensure compatibility between your mobile device and the Rapid Ring app.
  • Test the Rapid Ring app and the Live View on both cellular data and wifi connections to see if one connection type works over the other.
  • Test the Live View on the regular Ring app to see if it works without issue there. If it does, it may be a better option for you than the Rapid Ring app, as you will have access to all of the features available to manage your Ring devices in the Ring app.

I hope these troubleshooting tips help. If you’re unable to use the Ring app to access Live View and manage your Ring devices, please follow up with our support team at one of the numbers available here for further assistance. If you are outside of the US, please visit here to see how to contact support. :slight_smile:

Same as a lot of other users main RING app the live view works fine with -54 signal strength but the Rapid Ring app has stopped working and it’s been working fine for years. Come on Ring sort this app out as the “poor connection” is a red herring especially if it’s work ok on the main ring app.

2 Likes

I created an account to add my voice to this: rapid ring says my connection is “too weak” to show video and never connects now…yet the main app loads video fine.

This is a new behaviour that only just started after years of using both.

1 Like

I logged into my account also to add my voice to this: rapid ring says my connection is “too weak” to show video and never connects now…yet the main app loads video fine.

This is a new behaviour that only just started after years of using both.

SORT IT OUT RING.com Please

1 Like

Your solutions do not work! What is happening to Ring?

Bunch of morons at Ring decided to discontinue Rapid Ring app? Why the hell is not working, what is the reason behind the issue? It was working great for years. Please explain what’s going on. Let’s cancel the subscription if they think this is their decision.

1 Like

They have stopped supporting the Rapid Ring app and it will completely stop working altogether sometime in July

Rapid Ring complains of weak signal. Ring App sees live view just fine.

IOS 15.5 on iPhone SE 2020
uninstalled Rapid Ring and rebooted
Installed Rapid Ring 1.39.0 (18 h ago)

Both of my 5Ghz band

Ring Doorbell Pro
Transformer good
RSSI -30 (green)

I feel it’s the rapid ring app, since ring works, it’s just slower to open and get to the live view.

I have the exact same issues…works great on the Ring app, and Rapid Ring never loads live view and complains of weak connection. All checks out great and Wi-Fi signal is great/strong. This has become VERY frustrating.

1 Like

Another disgruntled customer here. Tried all of the above. Ring app works fine, 55RSI, Fibre to home connection.

I’m worried about the messages regarding the discontinuation of Rapid Ring, using Ring app is not practical for connecting to the doorbell before a delivery driver starts walking away.

4 cameras and the Ring alarm, let down because of a lack of customer support and sensible maintenance of the apps. I really just hope the Rapind Ring rumours are not true and someone from their Engineering team is properly looking into what’s causing this.

1 Like

Poor customer support from Ring for the Rapis Ring which is such a good app. It’s definitely the app and nothing to do with weak or poor connection. It’s a shame because I can see a lot of folk moving away from ring if rapid ring stops working for long periods. I will not recommend ring products in the future unless the Rapid Ring app is fixed.