Rapid Ring app black screen when responding to notifications!

Hi all,

Over the past 3-4 days (seems to be since updating to IOS 14), the Rapid Ring app displays a black screen when responding to notifications (motion and doorbell activation). It shows the Pre-roll in the top corner perfectly and all the buttons on the bottom of the sceen however the rest of the screen is black. When I close the app and re-open it normally (not responding to a notification) and enter Live View it works just fine. Only getting this black screen when responding to notifications. The main Ring app is working just fine when responding to notifications but I mich prefer the Rapid Ring app as it loads the video feed so much faster… Anyone else experiencing this issue?


I literally have the exact same problem. Get the instant notification…Awesome…view it…black screen. Exit out and open the actual ring app and it views perfectly. Its not the router/ wifi speed. Its the app. I may actually delete the rapid ring app and just use the old one at this point. That is, until they fix it. I have noticed you can view the cameras in the rapid ring app, but not if its during an actual RAPID RING NOTIFICATION!!


Same here. Very annoying.


Hey neighbors! Can you please try uninstalling the Rapid Ring App, restarting your phone, and reinstalling the Rapid Ring App? Once that’s done, let me know if you’re still receiving a black screen upon answering a notification.


Hi Caitlyn,

Just tried this, unfortunately the problem still persists :frowning:


I tried this as well. The video come up fine when tapping on the first motion notification but every subsequent attempt resulted in a black screen. I am using an iPhone 7+ with iOS14.

1 Like

Thanks for giving those steps a try, neighbors! I’d like to have my team take a closer look at this but I need a bit more information first. If possible, can you please take a screen recording of what’s happening when you’re answering a notification? I’d like to show my team the black screen that you’re seeing so we can determine what’s going on. When attaching this video, you will need to compress the MP4 file into a ZIP file, as ZIP files can be attached to your reply and not MP4s. In addition, you can upload this video elsewhere, such as YouTube, and then share the link to the video in your reply

Yes have been for several months now bout to junk it and go with arlo

I am having the same issue. When receiving a notification it will show a black screen. I will hit the red button then open the ring app and see a live view.

all this started a few days ago.

Hi Caitlyn,

Sorry for the late response! Have been busy woth work etc. I have attached an image of what happens and I’l take a video in a bit to show what happens in full.


Hi all, yes I’m having the exact same problem with my iPhone and since latest iOS update. All the same problems mentioned. Have uninstalled app and re installed too

I am still getting this issue with the last update - now on V1.15.2.0

Seems to have started with iOS14 update.

I’m also getting an issue with Rapid Ring when I click on the notification when wearing AirPods and the app drops the BlueTooth connection and reverts to speaker for sound only. I’ve resorted to disabling the Rapid Ring app.

I have been getting this for a little over a week now, still on iOS 13.3.1. App version, when this started it was a app version before that.

I’m getting the same thing. I’ll get a rapid ring notification on one of my cameras. I’ll click the notification to see what’s going on and it will load the app and display everything like it would normally but no video feed. You can hear sound and all that from the feed but no video. It’s not my phone or my wifi for sure. My regular ring app works fine.

Rapid Ring app now upgraded to 1.15.2

iOS upgraded to 14.1

Still not able to view video on RAPID RING app - see screen shot.

I can see Live View in the main RING app when out and about.

I can see Live View when using RAPID RING whilst at home on my WiFi network.

This issue occurs when using 4G/LTE out and about with the phone.

I have uninstalled and re-installed the RAPID RING app several times and also checked the local firewall

Any ideas or solutions?

I just added two stick up cameras and mine is doing the same thing now. I get a motion activation and when I look it’s a black screen.

Hi neighbors. To build upon what Caitlyn has said, if you have an active VPN, see if temporarily disabling fixes anything. There might be an additional security measure blocking the Live View. You can also try to reset the network settings on your phone to see if this will allow the Live View with the Rapid Ring app. If this doesn’t correct the black screen when answering notifications, I would also suggest getting a screen recording so our teams can investigate this. Thank you.

Same issue just happened today. The crazy thing is that it worked fine the day before. Tried it from two different WiFi locations and also through cellular data connection. Same issue.

Version is 1.19.0 (


Also wanted to add if it helps that the interface became unresponsive no matter on what buttons I was tapping.
This on an iPhone 6s