Problems with Ring indoor camera

Hi

We have multiple problems with our indoor camera:

  1. On the ring app, the preview icon always shows up as a black icon. Our other cam always shows a picture from the las seconds or so

  2. When trying to switch to live mode, in most cases, we are getting either an error message that the connection failed and/or that the camera is applying security update.

I tried to reset the camera multiple times and and app is showing up as running the latest firmware version.

The WiFi is not the problem as the access point is 5 feet from it and other devices are working fine with this access point.

Any suggestions please?

Thanks in advance

Itamar

Try powering off the Camera for a few moments, then powering it back on. Please also check the area for any electronics or appliances that might interfere, and consider any encryption settings, or VPN that might be enabled on your mobile device.

As this is only happening to this device, I recommend resetting the Camera if the above steps do not work. This can be done by holding the setup button for 20 seconds. Once this step is complete, please reconnect your Ring device by following the steps in this help center article. :slight_smile:

Hi

I tried what you recommend and hard reset the camera.

I re-added it to my system and while the setup process was completed successfully, the camera is stuck in a loop where it works for a few minutes and then says it installing a software update.

The device health status shows it up to date.

What else I can do?

Thanks

Itamar

Excellent work completing those steps. In the case that there is an update attempting to go through, try placing this Camera close to the router. Otherwise, this should not be happening.

If this concern is persisting for you, please give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.

Thank you very much, I will

Itamar