Peephole Cam wifi setup fails consistently

I am trying to setup a Peephole Cam and it consistently fails to connect to to my wifi.

I used two phones and two different wifi routers (I used the 2.4 GHz frequency).

I followed the steps noted here and step nine fails. I never get the option to choose my wifi network. It immediately skips to fail.

Here is the outline of my steps:

  1. With my mobile connected to my wifi router with Internet access and I launched the setup wizard.
  2. I got to the <Add a Ring Product> step and proceeded.
  3. I chose <Doobells> and scanned the code on the device.
  4. I selected the location that I had setup before hand.
  5. I named the Peephole device.
  6. I chose <I’ve installed it already>.
  7. I inserted the battery in the device and selected <Continue>.
  8. I chose <The Light is spinning> as the light was spinning on the device.
  9. It gave me the option to connect the phone to the Peephole
  10. I received the option to choose the <Device to use with Ring>
  11. I chose the Ring-xxxxx wifi
  12. My mobile device indicates that the connection is successful but the wizard indicates that something went wrong.
  13. Whenever I choose <Try Again> it asks me if the light is spinning
  14. I choose yes and tells me that something went wrong.

I basically cannot get past that point.

I have used two different phones to launch the setup and also two different wifi rounter and it fails in exactly the same way.

Hi @hotarobin. You’ve done a good deal of troubleshooting already, so I’ll just suggest this. Try resetting the device by pressing and holding the setup button for 20 seconds, then releasing. Then, on your phone, make sure location is turned on, bluetooth is turn off, wifi assist/smart network switch is turned off and there an no special characters in your wifi password. This should allow you to setup your device. Another test would be to see if you can connect your Peephole Cam to a wifi hotspot. That will tell you if there is a network problem. I hope this helps!


Thanks for responding.

I tried a third Andriod phone and I was able to get it to work in the first try. Location services were turned on, bluetooth was on and Smart Switching was off. I still don’t know exactly why it worked because I had those same settings on the other two phones. It was very strange!

I forgot to update and close and accept this solution.



1 Like

Hi @hotarobin. Great to hear! Some apps on the Android have been known to conflict with the Ring app. That list can be found here.