Not working right

Got the peephole doorbell Saturday
Installed Saturday evening.8/1/20202
Worked great 8/2/2020. Started to fail 8/4/2020. It said connection error. Now it connects and goes off into a black screen 5 seconds after love video has started

Rebooted phone
Reinstall app
Same problem
Black screen 5 seconds after love video has started. It worked good for 2 days.

Dissatisfied customer I feel like I want a refund.

Hi @Graphite07! Thank you for trying those steps to resolve your video concern. As you mentioned video occurs sometimes, or in the beginning seconds, it is likely that your Ring device, app, and network are attempting to deliver this video. This is good news, as there is likely an easy fix!

Video connection concerns are often related to wifi, mobile device, or Ring app communication variables. The best first thing to check is your wifi signal strength, or RSSI, which can be found in the Device Health section of your Ring app. Check out our Community post about RSSI for tips on optimizing this signal strength.

Removing and reinstalling the Ring app is a quick way to ensure it is up to date and optimally integrated with your mobile device. On your mobile device, try testing video on wifi only, and then on data only, to see if either connection is more efficient. Please also ensure bluetooth and VPN is disabled.

If this concern persists, feel free to try a reset on your Peephole Cam, by holding the setup button for 20 seconds. Once completed, perform a new setup in the Ring app. I recommend also checking the ribbon cable is securely plugged in on the Peephole Cam. Feel free to let us know how this goes! :slight_smile: