No Live View

I have a strange issue. I cannot get Live video while away from home. I am NOT connected to any wifi at all while away. When I touch the Live feed video, it says “Activating Device”. It spins for about 15 seconds and says “Live view ended” “Reconnect”. Now, I never get to see the live feed BUT I can go see it in my “Event History”. This kinda defeats the purpose of having a security camera if I can’t talk or sound an alarm if an intruder is on my property. It should work correctly.
I have spent many days with Ring support and not had any luck so frustration is setting in. I bought 2 Floodlight Cams and ordered the Ring Doorbell Pro and I want them to work as they should. That’s not happening.
I will mention that I have uninstalled and reinstalled the app twice. That didn’t work. When I am home and connected to my Wifi, the live feed works but when I disconnect from wifi, it does NOT. I work in a building that has a repeater for our cellular service and I always have full bars. Reception is perfect. I uninstalled my mobile Anit-virus as I read that Ring says AVG could affect performance. That didn’t help either. I am at a loss. I don’t want to take these products back as I think they could be good if not great when working properly. Any advice or suggestions?


I have a rare day on the road tomorrow, I’ll try to live view my floodlight from my cell-only connection and see what happens and report back.

This is a good reminder to try this stuff before my 30 day return period is over. I’m having various disappointing issues.

I HAVE found that using the 5.0 frequency wifi on my phones while at the house seems to help connecting to live view (I was having that problem at home). The cameras only work on 2.4 frequency. I read on the Rung site that competing wifi devices can interfere with connection. I was getting the same thing you described, it would just sit and spin and not connect at all sometimes.

Oh, and I feel your pain on the tech/customer service. It’s been less than stellar in my experience after purchase. The lady I spoke with before buying was awesome, everyone I have spoken with since has been a problem…starting with language barrier. Seems like offshore customer service farms to me.


Agreed. I have had a couple that have been very helpful and want to help but others… Not so much. I just don’t understand why it works fine with wifi but not cellular. The last person I talked to told me it was my carrier so I called them and they said it was the first they had heard about an issue with Ring and cellular data. What’s weird is last night, while sitting in my livingroom, I turned off my wifi, using cellular data with only 2 bars of signal, and it worked twice. Never did get it to work again. It almost seems like as it is “activating the device” , the image of my home is there but very, very blurry. Bad enough to know it’s not a house really. Anyway, it sits and spins then says live view has ended. No error or anything. A button to reconnect and it does the same thing again. Frustrating for sure.

I did a test today, once. While in a vehicle that was moving and should not have had any wifi available. My phone connected to live view pretty quickly. I was probably 70 miles from home. AT&T phone.

I have a theory that there is an issue with it trying to connect to live right after being triggered. Just a theory, but I have some issues with connecting to live view right after a motion alert. Like it cant walk and chew gum at the same time…the recording has to stop from the trigger before you can access live view. That’s probably not the case and may not apply to your situation…just a thought I’ve been having.

My connection to live view seem variable like yours. Sometimes right away, and others sit and spin. I did notice that my phone wants to connect to the 2.4 frequency when I come back home even thought the last wifi I was on when home was the 5. I went in to the 2.4 connection on my phone and deactivated automatically reconnect and left it on in the 5 connection. I may be seeing improved connectivity but I’m still evaluating. Again, this doesn’t apply to your problem, just throwing out info as I type.

Man, the spellcheck on this site is horrible to use. No intuitiveness at all

I got the same error message on my camera, turns out it was due to a power failure and I have to push the reset button on the camera to get it working again, unfortunately I am on vacation 1000 miles away so camera is not working, support have not been any help whatsoever not happy with the situation. Not going home until March.

1 Like

Great point. I need to switch off the power on the floodlight cam then back on and see if it requires a reset. That’s a deal breaker for me and I’ll send the thing back if that’s the case. It requires climbing a ladder to reset the floodlight. Not something everyone can do with ease.

I’m sorry you have this problem remotely. You buy a product that tells you it can be your eyes while you are away, then it doesnt work.

I now understand the folks (customers who answer questions) on Amazon, who, when I asked questions about the product, replied “do not buy” and “good luck”.

1 Like

I have had a similiar problem with some Arlo cameras requiring that I press a reset button from hundreds of miles away. I solved that, at least in part, by putting these indoor cameras on smart plugs that I can turn off using smartthings, then back on. This seems to reset the camera and get it back online. Won’t work with a battery operated doorbell cam for sure but you could probably put a spotlight/cam on a smart switch and recycle it that way.

I am pretty sure my Ring 2 Doorbell camera is going to be pretty useless to me once I leave home. It will need some kind of attention I can only give it if I am here. I think I will be sorry I invested the money in it.

Thanks will give it a try when we return home unfortunately not until March.

I also have no live view on one iPhone (iOS 13.3), the other one works fine. Funny that, although “Activating Device” pops up and the blue ring spins, it is recording. When I go back to history, all attempts to activate live view have been recorded. But as others have mentioned, I would prefer live view worked so I can see in real time. Not sure why it would work on one phone ut not the other?

If I had known how frustrating this was going to be I would not have bought ring


I did a test from about 80 miles away and pretty sure on cell signal, not wifi, and I was able to see live view just fine, fairly quickly. I’m on a new Samsung Android phone.

What Ring did tell me is, if you get a motion alert, be sure to either tap on the pop-up (which goes away ridiculously fast and still haven’t found where I can lengthen that. They tell me its a cell phone setting not a Ring setting) or swipe down from the top of the phone within 30 seconds and it will connect to live view. That seems to work OK. They say if you try to go to live view by opening the app AFTER an alert and tapping on live view within 30 seconds, it wont, because it has to finish the recording cycle. That seems like a flaw to me. Why could it not allow you to go to live view, from any direction including opening the app without affecting recording? It’s a software issue bug. It’s basically the same function as using the swipe down notification menu.

I think I’ve decided to keep the camera, but it still has some stuff I’d like to see improved. It works “good enough” and was easy enough to install and set up. Not great, but OK. We really wanted primarily a camera facing that way we could see on our phones because there is no fast way to see that direction from our house quickly without running to the only window facing that way at the extreme upper end of the house, and also something that will pick up people, where our driveway alarm only detects cars (steel). It does that, but still is alerting on a cat at night and my wife’s van pulling in and out of the garage while in “people only” mode…both due to reflections from glass/paint shine on the van and a stainless steel table in view at night that the lights reflect on, the best I can tell from the behaviour, my own testing and the Ring statement about reflections triggering motion when its not supposed to. They know this camera has this flaw. Disappointing…but I will keep it and deal with it.

Thanks for sharing that information. I will try swiping to see how it works. I too am very frustrated with the shortcomings of this Doorbell camera. As has been said elsewhere it does not seem to me that this was really ready for the market yet. I am a Smart House geek and this has been one of my more frustrating devices. I am sure it will be totally useless to me if I am not close enough to home to keep pulling the battery and resetting the camera to try and get it to do it’s job.

My current biggest gripe is that it takes so long for the camera to sense movement and turn on that those of us who just walk up to the door and come it (as opposed to ringing the bell and standing there) barely get recorded at all. I have tried all setting but it seems impossible to pick up someone more that five feet out without also getting every car that passes by - jus the tailights if I am lucky. It seems like movement towards the camera does not trigger much until very close. I would most likely onle see the back of a Porch Pirate as that is mostly what I see of the delivary people.

I’m still in the Amazon 30 day window and struggling whether or not to send it back along with the Chime/Extender that I should not even have needed in the first place. Increasing my RSSI from -54 to -33 (when it is working) has not made any difference with my complaints.

1 Like

I’m not able to receive live veiw on my backdoor cam. I can get it on my front door doorbell.It’s been a week or longer. Any ideas?

I have EXACTLY the same issue. What phone do you have ?? My husband has a Galaxy Note and his works perfectly away from home. I have a S10+ . Both work at home but mine does what yours does when it is using mobile data. Started after the Android update last month

I have the same issues, I am very disappointed with the product.

1 Like

I first started experiencing exactly the same issue as Cn2017 describes around the end of last year. While on a trip to Japan last summer, Live View worked perfectly for my Ring cameras in Hawaii (albeit with a slightly-added “lag” response) with mobile data provided by AT&T’s international providers in Japan. Suspecting that the issue may have been related to a Ring app and/or Android update, I gave the matter some time to resolve itself. After months, the issue persists. After chatting with a Ring customer service representative last night, I stumbled upon this discussion thread. Just in case it matters, I use a Samsung Galaxy S10e phone.

Hey neighbors! I appreciate everyone taking the time to share their experience in detail. Live View connection concerns are often related to network or mobile device connection, and so these are the best variables to start with. Please check the following:

  • A good RSSI, or signal strength, in the Device Health section of your Ring app.
  • Battery is sufficiently charged if applicable.
  • Wifi speeds, interferences, and distance to router.
  • Test live video on Cellular data only, and on wifi only, with your mobile device.
  • Remove the Ring app, and reinstall the Ring app on your mobile device.
  • Disable bluetooth, vpn, and close any other open apps on your mobile device.
  • If you are using Android, please check out our help center article about conflicting apps to see if it applies.

Feel free to keep us updated on the results, and please let us know if any of the above steps help to resolve your concerns.

there’s another thread on the same topic. I also have a Galaxy S10+ that live view on data stopped working with Update 11 a few weeks ago.

When you post here, remember to list your phone, OS, and version/update#

It turns out my issue was related to the latency of my VPN program. Once I turn it off, everything works fine.

iPhone X iOS 13.4


I am having a similar issue. At home on my WiFi network I can see the live feed perfectly. However, at work, on celular data only, I cannot. If I connect to our corporate WiFi it works perfectly but I prefer to keep my device off of the corporate WiFi. Regardless of how I am connected, it always records the events and I can rewatch them, I just cant go live on cellular data.

I also have this same exact issue with Amazon Cam for our interior security. On WiFi it always works and on cellular it never works.

I am using an iPhone X running IOS 13.3 on Cricket wireless (AT&T towers)