NEW Ring 3 stopped connecting to wifi - even after reset and router reboots

Hi Team I have a new ring 3 doorbell (purchased April 2021) that has been working for a few weeks, but kept dropping the wifi every now and then , but now it will not connect to my wifi at all , I have been through EVERY recommended process, including the full 20sec reset - with no success - I actually see it connect to the AP in the log and showing STA-ASSOC with packets going back and forth like every other connected device, but then it drops out and I get the right hand side white lights - I have tried rebooting the router/AP multiple times and having the ring device right next to the router and still get the same problem. Battery is also fully charged etc… I have multiple devices connecting to the wifi including Alexa echo , TV, mobile phone, MacBook - so I know the wifi connections to the internet is working fine . From the Ring app I’m getting 11mbs download and 8mbs upload.
After trying everything for the past week, can I have it replaced please - bought from Argos in the UK on 14th April

1 Like

Hi @Spud312r. A right side flashing light is an indication that your Doorbell is having a difficult time connecting to your phone. What type of phone are you using? Try setting it up with a different phone or iPad, if possible. Here are a few other things you may need to adjust:

  • Turn off any active VPN

  • Turn off Bluetooth

  • Make sure Location is turned ON and permissions are enabled

  • Turn off your Smart Network Switch/Network Assist

Changing these settings on your phone should allow you to connect. Let me know if this works!