new ring 3 alerts every car on street

I got a new ring 3 doorbell and it was alerting every car on my street (my house is far back from the road). I changed the distance sensitivity and it didn’t fix it. Then, I found people only mode and yay, it was fixed! I went from 32 notifications a day to like 3. Beautiful.

Then it started back up with notifications and when I checked settings, people only mode is no longer one I can change because my Ring protect trial expired. I am not interested in Ring protect right now.

Any other suggestions of what to do? I don’t want the sensitivity so light that I never get notified, but I can’t seem to fix this. Help?

Go into motion setting and turn the zone off that “sees” the street. Mine was the top zone.