New "Privacy Zones" Feature Not Available On All Cameras

That is correct @Gmb, looks like it has simply not reached all devices yet. Contacting our support team was a great way to ensure it is not caused by anything other than the slow roll out. As mentioned previously in this thread, our team is working to get this out to all neighbors as efficiently as possible. I will, of course, share this thread with them for continued feedback and desire for the feature. Keep an eye on the Community for any further updates on this feature being available for all devices and neighbors. :slight_smile:

Hello, can you give us an update on the roll-out of this feature? My two Doorbell Pros both have it, but my two Floodlight cameras still don’t. All four were purchased and installed last year and show that their firmwares are up-to-date.

I have two floodlight cameras on two sides of my garage. When I go in the Privacy Settings on the floodlight camera I bought two years (floodlight cam #1), I have the option of setting a Privacy Zone. This allows me to block off part of the recording.

However, when I go in the Privacy Settings on the floodlight camera I bought last year (floodlight cam #2), the Privacy Zone setting is not listed. Only the enable Audio Streaming and Recording option is listed.

Any reason why floodlight cam #2 doesn’t have the privacy option, even though it was purchased more recently (both from Home Depot)? Interestingly, floodlight cam #2 is where I really need the option, as it is picking up part of my neighbor’s yard. I’m considering physically swapping the two cameras but was wondering if there is a reason before I do that. Both floodlight cameras say “Up to date” for the firmware.

Just got off the phone with support, still no date on the update, seems like this need isn’t a priority for ring. I wish they actually said this in the description when ordering, I would’ve just bought an old version that actually has all the features.

I just checked my 2 yr old floodlight cam. It does have it. Never noticed it before. But I never needed it. Strange the newer ones don’t. Same model. My guess it’s connected to a firmware update.

both my floodlight cams (bought about 6 weeks ago) have had privacy zone capability added in the last few days.

It must be rolling out slow. But it’s coming I guess.

Hey neighbors! If your device has the most up to date firmware, it should have the Privacy Zone feature. Please ensure you go into the Ring app > Main Menu > Devices > Device in question > Device Settings > Privacy Settings > Privacy Zones should be there. Please ensure you have the most up to date app version as well and if you still cannot find this feature there, please take a screenshot of this feature missing within your app and reply with it here! :slight_smile:

Hi Chelsea,

I’m on app version 3.28.1 which is the most recent available Android version. I still don’t have Privacy Zones on my v2 Spotlight Wired Cam.

Screenshots attached.

EDIT: Also installed the app on an iPhone, version 5.28.0 for the Ring app and don’t have the Privacy Zones option on that device/OS either.

1 Like

My Spotlight Cam now has Privacy Zones!

I’d been checking more frequently in the last few days since this thread re-gained traction. Privacy Zones didn’t show this morning but they’re there now!

Hey @5150Joel. Thank you for coming back and letting us know that you now have this!

Neighbors, we can look more into this for you if you’re able to provide screenshots, similar to how @5150Joel has, if you’re still not seeing this. Please reply into this thread here if you’re still not seeing this feature under your Privacy Settings! Thank you. :slight_smile:

I finally have the option to use privacy zone settings on my Ring Floodlight.

Would be great to have the option to either tilt the box or be able to have other positions than just a square or rectangle.

1 Like

We added 4 cameras last week and all but one has the option to add a privacy zone. I’m told this is still being rolled out, but this thread is from 2020. Do you know if this is still ongoing? We just purchased these a couple weeks ago. I would think they should have it by now.

Hi neighbors. I would first ensure that your Ring app is up to date as well as the firmware for your Cam. You can find information about your Cam in the Device Health section of the Ring app. If the firmware shows up to date, try resetting the Cam and then reconnecting it to wifi. You can reset your Cam by pressing and holding the setup button for 20 seconds, then releasing. Once reconnected, check to see if your Privacy Zones are available.

If you’ve tried this to no avail, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.