My Wifi and ring base are not able to work again.

The Ring base does not accept my wifi credential from eero wifi connection. I have follow all the steps shown on the ring app:
Connect your base station to the ring app - DONE
SELECT Wifi setup Option - DONE
Wifi Network: - DONE (EERO)
Enter the password: - DONE
The error Message from the app can be read as follow: Wifi Connection error: We can’t connect due to an incorrect password or poor wifi connection. We suggest you first check your wifi connection and then enter your password again

Note: The eero router is close to the Ring base and I have tested wifi credential from multiple devices. Also I’m using the same wifi network, same pass, same everything that Ring base used to work with in the past and now the base is not able to work with the eero wifi as it used to do.
What should I do with this Ring reliability problem?

Looking forward to your guidance.

Hi @ZENER! I recommend trying this on a guest network, which should help to factor out any custom network settings. Please enable the guest network on your eero with a simple SSID and password, without special characters or spaces.

If this concern persists, try using ethernet connection, if possible. Our support team is also happy to assist with more in-depth troubleshooting if network connection cannot be obtained with your Base Station.

Thank you for your response.

I have made the recommendation to connect through the guess account but it did not work.

then I proceed to the connection via ethernet and it worked. Apparently Ring’s wifi is not reliable in some circumstances. I will keep this connection because I have no other alternative.

thanks again for your help

Forgive me if I’m out of line. Lily-white brand-new here, first post in fact.

I have experience with other IOT devices not connecting to WiFi. I’ve discovered that if WMM (WiFi Multimedia) is enabled on the router’s 2.4GHz radio, IOT devices will not connect. Same problem possibly?

I’m not familiar with your router, so I’ve no idea if this is user-selectable in its firmware. My experience is with a Linksys WRT3200ACM, with OpenWRT firmware. YMMV.

Good Luck


1 Like

I had this same problem and finally got it resolved. Two simple things to try in order of difficulty:

  1. Unplug your router and any wireless devices. I have a mesh network, so I had four devices to unplug. Leave them off for 30 seconds or so and then plug back in. See if your base station will connect.

  2. Unplug the base station and get a small scredriver to remove the battery cover on the back. Pull the battery which may be a little tricky, so be careful to not pull out the wires. Leave it off for about 30 seconds and then plug back in and replace the cover. Plug into power again and try to connect.

I’ve seen various reports of #1 working for people. I needed #2 which worked perfectly.

1 Like