My Ring camera announces everything twice on my Alexa devices

Hi,

1 Ring battery camera and several Alexa devices, spots, shows, dots etc. When motion is deteced, it announces “Motion detected at the front” and then repeats it. Is this right? Can I set it to only say it once?

Hey @millenium_cowboy. For the devices that you do not wish to have the announcement, you will need to configure this setting with those specific Alexa devices and turn off these motion announcements. :slight_smile:

Hi, thanks for that, just not particularly relevant to my problem.

1 Like

This has just started happening out of nowhere as of 7/21/2020 on my alexa ring device. With any motion detection for the month I had it. alexa would repeat the notification once. Just today for no apparent reason, she will repeat it twice. “Motion at front door” *half second pause* “Motion at front door.” At onne point she even said it three times in a row! I tried resetting my ring doorbell by taking out the battery, Unplugged alexa multiple times. Disabled the ring skill and re-enabled it multiple times, and she still wants to say the notification twice in a row. I really hope you guys can fix this bug or else I might have to silence motion notifications from her.

I have the exact same problem. Alexa started annoucing “motion detected at the front door” twice about a month ago. Also - I’m not sure if this is connected or not - when I ask Alexa to communicate with my front door (echo devices without a screen, i.e. audio only), she connects successfully every time. When I ask to view my front door on my Alexa Echo Show it only works about 50% of the time. I’ve checked the signal strength of the WiFi at the front door and it is very good, so there must be a different problem.

Mine does the same thing. So annoying. I had to unlink my dot also as it announced twice on the dot then twice on the alexa.

I had this issue and discovered that, in the Alexa app, I had “Motion Announcements” enabled under Devices - Cameras - Device Name and also a routine configured for Alexa to announce a customized message when motion occured. I found it best to set up a routine if I only wanted the motion announcement to occur on a single echo device at specific times and to enable “Motion Announcements” under the specific device settings if I wanted announcements on multiple echo devices for every occurence. And, if that is not confusing enough, don’t forget that the Ring app on your phone can also be configured to provide a sound and popup for motion events. However, I beleive the Ring app alerts only occur on the device on which the app is installed.

I have the same problem and it also started a few months ago for me. It’s so annoying to hear her say it twice. Anyone figure it out?

Hi @bubbafish! The best first step is to ensure both the Ring app and Alexa app/ devices are up to date. Next, please check the Alexa app for the Ring skill, added Ring devices, and any routines you might have enabled. There may be an announcement routine or skill enabled twice, or two options that might be overlapping. This is best checked within the Alexa app. I hope this helps! :slight_smile:

Ok, I ensured that my Alexa app, my Ring app and my Alexa device are all up to date. And I double-checked to make sure that I have no routines set. Then, I disabled the Ring Alexa Skill, then re-enabled it. But the double-announcement problem is still happening. Pretty sure it’s a bug since I’m not the only one this is happening to, and it started happening a few months ago without my having made any changes.

Thank you for trying those steps, and providing an update on your results! As you have factored out both apps and integration settings, lets check the Ring device itself. Please power cycle your Ring device by removing power for several moments then reapplying. For battery powered Ring devices, this is done via removing the quick release battery. For wire powered Ring devices, this can be done via plug adapter or breaker switch, depending which is easier.

If your battery is not the quick release version (unable to power cycle) or the power cycle did not resolve this, please attempt a reset on your Ring device by holding the setup button for 20 seconds.

This should resolve any concern with multiple notifications for one event. If it does not, Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

My ring just started this morning saying motion at the front door twice. I contacted customer support and reset my dot, deleted and resynced my ring and it is still doing it. Any help?

Hi @Nicole15. In addition to the previously mentioned suggested steps in this thread, you can try rebooting you internet router. Allowing all of your devices to establish a new connection could be just what you need to get the announcements to only sound once. I hope this works for you!

There is another thread about this where it is also happening with phone notifications. It is also unresolved with scads of users having the same problem, including me. It seems that for some reason Ring is pushing through notifications twice. Some people are having luck turning off “rich notifications” and just receiving one standard notification. Which is fine for Echo devices but limiting and frustrating for phone notifications.

1 Like

My PC suddenly started announcing twice only on one camera of the 7 we run. Can’t find anything that is related to that single camera. My phone and laptop only announce once, but my PC announces twice on the spotlight cam.

Issue Resolved (sort of):

Hi all, I’ve recently encountered this exact issue and had noted that it only started when my free protection plan expired. I’ve just taken out the ‘protect basic plan’ and since then my notifications are back to normal (announced only once).

I’m not 100% certain but it could be related to the use of rich notifications, a function only available when you have a plan in place.

Probably not the answer you wanted but hopefully useful to some of you. Be interested to know if this coincides with your own experiences.

1 Like

Issue Resolved:

I read the post by Jason-S indicating the duplicate announcements started when his free protection plan expired. It’s been a while since the duplicate Ring announcements started on my Alexa Show, but it’s also been a while since my free protection plan expired. So, I decided to test out Jason-S’s theory and subscribe to the ‘protect basic plan’. Moments after paying the $30 annual fee I walked out the front door, triggering the Ring motion sensor and Alexa announced there was motion at the front door - just once. Problem solved. Though, I think it’s ridiculous it requires a paid subscription to stop the duplicate announcements.

BTW - I have Rich Notifications active, so I don’t think that’s causing an issue.

Mine as of today has now spawned to FOUR notifications despite me trying to follow these steps. I don’t even know where to turn the notifications off. Makes me want to take the doorbell off my wall.

I had the issue with Alexa announcing twice I tested the theory with the subscription while on the phone with Ring support and it did not resolve the issue. I turned off Rich notifications and the problem was resolved. It only announced once. I turned it on again and it still only announced once. The issue is with the update and Rich notifications. If you turn off Rich notifications it will should resolve the issue. After contacting Amazon and in the phone for a half an hour and on the phone for over 2 hours with ring I was able to stop the second announcement.

Hi there, @Jason-S! Thank you for providing this update on your experience to the Community. Can you please confirm what Ring device(s) this is happening with, and if you have People Only Mode enabled?

Any other neighbors with a similar concern as this, feel free to also confirm this information.