My Kwikset Smartcode 888 doesn’t function with Ring

I keep getting an error message with my kwikset smartcode 888 deadbolt. It pairs just fine but doesn’t show whether the lock is unlocked or locked. It just says ‘can’t retrieve status’. I’ve tried moving my base station, I’ve tried removing the lock and re-pairing it several times, I’m not sure what else I can do :frowning:

Hi there, @Msgmth13! This sounds similar to this Community thread. A couple of neighbors shared success with checking settings that may pertain to the lock or an old system that the lock was operating with.

If this does not work, and re-adding the Kwikset integration also does not resolve you concern, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.