Low Battery Notice on a Wired Stick Up Cam??

I’ve got a brand new wired stick-up camera. In the app, I’m getting the following error:

"Live View is disabled because [camera name] has a low battery.

Even though [camera name] is hardwired, excessive use or cold temperatures can affect battery life."

Again, it’s a PLUG-IN camera. What gives??

Thanks,

MT

7 Likes

I have the exact same problem now, work great for 2 months now I have the same notice and my camera is wired also no battery.
Did you ever get it figured out?

7 Likes

I have not figured it out. Just got the camera yesterday and still getting the notice–not always, but almost always.

I also don’t understand why the snapshot feature isn’t an option with the powered Stick Up camera. It’s identical to the floodlights without the lights. It seems like a pure app restriction, not a hardware restriction. Arrg.

4 Likes

That’s funny, because ours is saying the same thing…on the same exact day as yours. It also, is wired…and it’s only 2 weeks old!

3 Likes

Have you called RING about it? They are on west coast and I’m on east coast, so I’m gonna call when I can. We have another stick up camera that is only a couple months old and haven’t had this issue. We have only had this one for a couple weeks.

1 Like

Same problem here. Got the camera yesterday (March 30th). Live view not accessible because of low battery even though it’s wired.

I tried a factory reset a couple of times. Tested my wifi access, firmware seems up to date cam-1.4.15200.

Pretty frustrated by the situation.

7 Likes

I’m in Minnesota, at work now when I get home I’m going to try a few things, I was hoping somebody from ring would be monitoring these posts and maybe get back to us. Don’t even know who to call! So if you are monitoring let us know what’s going on! My wife has the app on her phone to same thing no live view says low battery( again we have no batteries in the camera I think it’s a 3rd generation, only corded). I have a doorbell Cam, and a spotlight cam, have had them for about seven or eight months, absolutely no problems work great, don’t know what is with this camera. Please ring let us know!!

4 Likes

my stick up cam is doing the same thing… plugged in with a low battery!?

4 Likes

Hey everyone I just called ring about this and they’re escalating it to a advanced support person. I’m still waiting on a response though. I’ll make sure to mention this thread in case they think it’s an isolated issue. My guess is that it’s a problem with the firmware since it sounds like numerous people are having this issue. I will post back if I hear anything.

12 Likes

getting the same prblem wth my wife’s phone and my 2nd phone. but not with the phone i used to set up the divices. it annoying.

2 Likes

Thank you for letting us know!

I was able to get my live view to start working again. I had to uninstall my ring app reinstall the Ring app from the Google store. Once I was in the new app I had to go up to the upper left-hand Corner going to the menu go down to the new features and enable the snapshot feature and event history timeline, it does look a little different when you tap on the camera view but it was working I hope it works for the rest of you.
Troy

2 Likes

Well Ring is aware of the problem because I called yesterday. They said they have had several calls. However, the problem was not resolved by the associate. She said it would be passed on to the proper deptartment to fix the issue. We shouldn’t have to unistalled and reinstall to fix the problem. Ring should be fixing the problem or sending a replacement camera…afterall we all JUST purchased these cameras. We have another stick up camera we bought in December and it hasn’t had this problem. So obvisouly these cameras we all have are a newer version and can actually take a battery for a back up. You have to purchase the battery for it.

4 Likes

I’m getting the same low batery notice on all 3 of my WIRED stick up cams. All are mounted up high and require an extension ladder to access.

I will be returning my system if Ring’s “fix” requires me to climb a ladder every time someting like this happens

5 Likes

I suspect this started occurring with the latest Ring app update. My Stick-Up Cam Wired is also just 2 weeks old and it was great until the app update a couple days ago. Sadly, that app update DID fix 2 issues I’ve had with Smart Lighting so it’s been a mixed blessing.

Hopefully, Ring will get it all sorted out quickly and release another app update which fixes this “Low Battery” issue (especially since the camera has NO BATTERY because it’s wired).

2 Likes

Greetings - I’m reposting my own post from another thread I started because it solved this problem and the other (no snapshot on gen-3 cams).

———————————

So, I have a 10-minute, non-adjustable snapshot feature as of today on my brand new Gen-3 Stick-Up Cam.

No idea what I did made it work or if there was a firmware update, but here were my steps:

  • I reset the camera in my office (so it was super-close to the router).

  • Using the Android app to set things up, I skipped the QR code scan and just chose to install it without scanning a code.

  • I went through the process, “Rome wasn’t built in a day…” yadda, yadda…

  • But, when it got to the updating firmware screen in the app, I just let it sit there despite not seeing any lights at all on the device (the screen says to wait for the blue light to finish flashing and there’s a skip button… I just let it sit).

  • After around 7 minutes, the forced tutorial checklist came up on the app and I went through it all until complete.

  • After that, I started seeing snapshots on the dashboard next to my other three cameras but instead of every 30s, it’s every 10 minutes. Better than nothing.

Marly from Ring just said on this thread (as did another customer) that Gen-3 doesn’t support snapshot. So they must’ve done something or I REALLY should go play the lottery tonight.

Also, while I did set the camera up on an Android phone, the snapshot is showing up on the iPad I use as a dedicated camera monitor.

As we all probably know by now (and if this works for you), this could all break tomorrow. The devs seem to dig toying with our emotions by giving and taking features from us.

Sigh. Good luck!

My “Low Battery” resolved itself around dinnertime tonight (~6 PM EDT). I did absolutely nothing to fix it but all of a sudden, my camera once again reported that it’s power source was “Power Outlet” (instead of “Battery”) and the Batter Level was “Unknown” (instead of “Low Battery”) as it should as there is NO battery. Unsure of what happened but it’s all working again including my Live View and motion detection.

2 Likes

We had the same issue. Our camera has been installed for several months and working fine. But I noticed a day or so ago that it had a red battery symbol in my ring app and it said battery was at 8%. It doesn’t even have a battery in it. We climbed a ladder, took it down, unplugged and replugged it in. And now it acknowledged it’s plugged in and the red battery symbol disappeared from the app. The power cord was not loose at all so we have no idea what cause this.

2 Likes

my stick up cam is plugged in, there is no battery because its plugged in and now says its offline.

Having the exact same problem. Can’t chat with support because it says “something went wrong. Try again” . ?