LiveView not working on Floodlight cams


  • Liveview won’t work on the floodlight cams.
  • Videos are not recorded on the floodlight cams
    (video works fine on my doorbell)


  • 3 ring devices
  • Two Gen 1 Floodlight Cams
  • One Gen Video Doorbell


  • RSSI readings on the floodlight cams are 43 and 36. The doorbell is 30.
  • My pipe is 300mbps and testing wifi only at each of the three devices I pull about 250mbps.
  • I uninstalled and reinstalled the app on my phone.
  • Setup the floodlight cams again.
  • I have no VPN
  • On my home wifi connection and I can only see video on the doorbell.
  • On 4G I can only see video on the doorbell

Error Message:

  • “We’re having trouble connecting…”

What works:
Literally everything else. Lights, turning the motion sensors on and off, motion sensors activating, lights activating when the motion sensors go off.

Level of annoyance:

  • At this point pretty damned high. This feels like a straight-up product issue at this point and since I bought them a year plus ago and just installed them I feel like I’m going to get screwed.

I’ve tried everything that I’ve read but still no joy. Any other ideas?

Sorry to hear about this, neighbor! It looks like you’ve covered just about every step we would recommend from our Live View troubleshooting post. Thank you for taking the time to cover all these steps.

The only other thing I would add here is trying out the Rapid Ring app to see if your Floodlight Cameras will connect to live view from there.

As this is your first time setting up the Floodlight Cameras, it is possible that your network settings might be impacting video, although it would be odd for the Video Doorbell to work in this case. Here is our Help Center article about the ports and protocols for Ring devices. If you have an advanced network or network features, considering these settings will help.

Feel free to let us know how this goes! :slight_smile:

I’m seeing this exact issue with my floodlight. Screenshots are being taken, the light turns on with motion, etc, but I can’t access the live view and the camera never records.

I have 2 battery cameras as well, and they aren’t seeing this issue.

My floodlight traditionally picks up a lot of video each night, as we have several outside cats that set it off. Is it possible the camera recorded too much video and that contributed to this issue? I didn’t think the video was stored locally, so I’m not really sure how that would cause the problem.

If I power off the light and then turn it back on, it works for a little while, but then stops again within a few hours.

Any other ideas?