Live-View not working

Live view stopped working on all my security cams about 7-8 months ago. I have tried everything under the sun to get it to work but no luck. Changed the router, opened ports explicitly, reset the cams multiple times, tried accessing through cellular data, tried to access live view through ring.com…no luck. The camera’s record and I can view the recordings but live view does not load.

Seems like many other people have had this problem and some of them had to give up on Ring products because of this. I am guessing I will have to do the same. :no_mouth:

Cox shuts off Wi-Fi every night at around 3 am and it knocks my camera offline and I find it difficult to get it reconnected.

Hi @user30549. It seems like you have tried all the basic troubleshooting steps I would have recommended for your concern. The next best step would be to give our support team a call at one of the numbers available here for further assistance. If you are outside of the US, please visit here to see how to contact support.

Hi @Scoopho. I would try rebooting your router by unplugging it for 10 seconds and plugging it back in to see if that helps. You can also try rebooting your Camera from the Ring app. We also have this Help Center article here that has steps that could assist with your concern.