Live view not working

I’ve gone through all the checks and everything is fine with wireless etc … Inuse to reboot my modem and it would work for a while, but now live view doesn’t work at all

Hi @calla! I know how important Live View can be, so lets definitely ensure we get this up and running for you. This Help Center article here is a great resource for troubleshooting Live View. If you’ve looked over that article, performed those steps and you’re still having Live View issues, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

1 Like

@calla wrote:
I’ve gone through all the checks and everything is fine with wireless etc … Inuse to reboot my modem and it would work for a while, but now live view doesn’t work at all

Hello @calla , a fellow Ring Neighbor @Sgtrn also had issues with his “No Live View” and he posted in this same “General Questions” forum. You might have missed his post titled, “No events or Live Feed.” Instead of me repeating it all here, go to this link and read my post there:

https://community.ring.com/t5/General-Questions/No-events-or-Live-Feed/m-p/54124#M4081

Almost all “Live View” or “Black Screen Videos” are Wi-Fi related isses. A strong signal connection doesn’t necessarily mean a good data connection. Hopefully, you too will find this helpful, as Sgtrn did. :slight_smile:

1 Like