Live view doesn't work on android devices with main account


I’ve been using Ring since last year, but 2 months ago the Ring app on Android doesn’t work when I try to access the live view feature. This only happens with my main account (who manages my 1 doorbell and 2 floodlight cameras).

My wife and my son have accounts, and I have shared the cameras with them, and they can access without any issues, but if they try my main account on their devices, it doesn’t work as well.

I tried removing the app on 3 different phones, clearing the cache settings, and on the 3 my main account doesn’t work.

Can anybody from the support team help me with this issue?

My husband, daughters and I have the same kind of issue. The app was working find on my device and our daughters’, but not my husband’s Android. We all uninstalled, reinstalled and now it no longer works for any of us, and says “You are not the owner, contact the owner.” Customer service was zero help, even though we have the receipt, own the Ring and the house.

We did attempt to reset the device, now the email I received says, “Contact the owner.” Not sure what else to try, other than purchase another security doorbell. Thankfully, Costco has some on sale, I am trying a different brand now, " Feit Electric Smart Video Doorbell With Wi-Fi Camera" and their other devices.

Would love to hear if you find a solution!

Good luck to you,

Hi @yolesol. This is pretty interesting. Are you able to Live View from the main account on I’m trying to see if there is a problem with the Ring account itself, or just the device. On your Android, try going into your settings and looking for a Wi-Fi setting known as “IPv4” and changing this to IPv6. Also, ensure that your are not using a VPN on your Android. Lastly, try viewing Live View on the Rapid Ring app. This app is designed specifically for Live View. Once we have the results of this information, we’ll be able to dive a little deeper and see if we can get to the bottom of this!

Hi Tom,

Thanks for your prompt answer. Here are the results of your requests:

  1. I can use my main account to access the Live View on
  2. Our Wi-Fi networks uses IPv6, and that’s our default option. Also, this issue occurs with 4G connectivity.
  3. None of the devices we tried use any type of VPN connection.
  4. The Rapid Ring App let’s me see the live view on my 3 devices.
  5. When I use my main account (manager) and access live view with the Ring App of any of my devices, it get stuck on the attached screen of the app

As the forum only let me post one image at a time, I’ll post the flow and error that my android device reports on the following 3 images.

I hope this information can be useful to solve the issues with the Ring app, it’s important for me to use all the features, because I’m planning to buy more devices for my home.


  1. When I access for the first time, I see this screen, the error ocurrs if I omit or see the new features.

On the first and later attempts to open the live view, the app always freezes on this screen when trying to access any of the devices with the main account.

Sometimes, Android gives me the option to nofify the error, if I access the preview before sending it, I can see this error message that the system provides.

Video concerns are often related to wifi or mobile device connection variables. As mentioned prior, check out your RSSI in the device health section of the Ring app, to ensure for optimal wifi signal. I recommend also trying out the Rapid Ring app, designed for optimal access to live view.

Here is our Help Center article for more tips on troubleshooting Live View concerns. As you mentioned using Android, please check for any Android apps that conflict with the Ring app. If further assistance is needed, please give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.