Live-Video only shows message "activating device ..."


I resetted and re-registered my Ring Door View Cam several times. Registration with the Ring app works so far, the wizard runs, it asks for the WiFi password and the device is displayed in the app.

When I ring or motion is detected, a message appears on my phone. But I can not watch a video, the live video window always remains black with the message “Activating Device …”.

Otherwise, the device appears to be connected normally. In the Ring App Device Status Settings I also see the battery status and the WLAN signal strength (RSSI - 52). Under Ring System-Status everything is green (All Systems ready). When I make the Internet Connection test , I receive an error that the test failed. But both devices (Ring Door Cam and Smartphone) are in the same WiFi. I can also see the DHCP lease for the Cam. The Access Point is 4-5 meters from the Cam.

Does anyone know of this problem? Thank you

I use a Sophos Firewall and I needed to open some ports for the Ring Cam and Smartphones. Finally I opened following Ports from LAN to WAN:

TCP 5223, 5228, 9998, 15064, 32882-65533

UDP 53, 67, 68, 123, 5353, 5001-65439

Now the live video stream is working and the WiFi Internet Connection Test finishes successfull.

1 Like

any suggestions for non-tech purchasers? The recording is fine but I can’t get LIVE video. I bought a component to strengthen connections but still don’t get Live video for more than a split second. The guy who installed thought I might need to call wifi provider to increase package?

What do you mean with increase the WiFi package? Are you not in a private network with your own WiFi access points? or is your WiFi limited?

I’m getting the same error message and my internet signal is good.

1 Like

My WiFi is good. My signal strength will only show RSSI readings. My WiFi tests are plenty fasts. My router is 20 feet from my front door. I get no live feed, no notifications, and no video when someone rings the bell.

Me too did you ever get it fixed

Anyone got the solution for this issue?
It says as solved but I don’t think anyone have any solution for this.
I am not getting live videos and not even ring notifications.

i have the same problem. I need higher bandwidth. I use Century Link for an internet provider. Have been trying to get through on phone and chat since Covid started. Of course they are busy with folks teaching from home, etc. but that’s my problem with the Ring. I tried buying an “Extender” but still can’t get a proper connection. So for now I have an expensive door bell.

I had the same issue. I went into my wifi admin and set up port forwarding on the stick up cams IP address on TCP port 15064. Now it works like a champ!

1 Like

How did you find your IP address for your device? Our internet provider said that ring updated thier software to rid this issue but we are still having the issues! im logged into our wifi admin but i dont know how to find the IP address for our devices!

You need to install a WiFi scanning app on your phone, scan your network and look for your device. Fing is a good app for scanning.

Downloaded the ding app. Still confused from there can you break it down for no technology ppl? Thanks

I am receiving the same message. Please let me know if you have received a fix for this.

I tried installing 2 of my 3 new cameras and am having this problem with both of them. No live video feed, message says “Activating Camera” but never links up.
I tested everything help told me to and all of my numbers are where they are suppose to be. BTW we have a Ring Video doorbell that has been working perfectly fine for months

Hoping someone can please help!

I had this issue while setting up my new ring doorbell however the issue with mine was that I skipped the firmware update while setting it up which I now believe was causing the live video and notifications to fail. When given the chance to update the doorbell, I did and the live video started working perfectly after that! Definitely worth checking for :).

1 Like

I have the same problem since I got the RING 2 device , too many calls with the customer service and nothing happen

This is unacceptable. When I want to view my camera it should show a video, plain and simple.

Hey neighbors! If you’re having concerns with the Live View on your Doorbell, and the solutions suggested in this thread do not work for you, then it may be best for you to follow up with our support team directly. They’ll be able to pull up your account and take a closer look at your device to see what may be going on. Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. :slight_smile:

I think it’s a cheek that the camera won’t work without the Internet. Even if the camera and the smartphone are in the same WLAN. I recently saw a program on TV about Ring, there is a suspicion that the camera images in the cloud are being evaluated with AI in order to find wanted people. So it also makes sense that the camera constantly needs internet. I will replace this camera asap.