Keypad (gen 2) not working

I just set up my ring alarm system. all components set up easily except the generation 2 keypad. I have tried to factory reset with button on the back. I tried pressing number one I tried pressing number five. I tried uninstalling the keypad then reinstalling the keypad n the app. I also tried to manually pair the keypad to the base station with the QR code. I tried unplugging and replugging the keypad in. I also tried to uninstall the Z wave but I get an error message when I do that. The number for Ring customer service is a busy signal. any help would be appreciated.

Hi @becky79. It sounds like you’ve run through most of the basic troubleshooting steps I would have recommended for when a Keypad isn’t working properly. I’d recommend following up with our support team directly so they can take a closer look at your Keypad and help get it up and running within your system. Please give our support team a call at one of the numbers available here, which should not provide a busy signal but rather different prompts to help you get to the correct team based on your device. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. :slight_smile: