Keypad Delays

Good morning. I am having problems shutting the alarm off when I accidentally set it off. I enter the code and the alarm still goes off. I do have 3 keypads. Can someone please advise. Appreciate any help.

1 Like

Hi @Gabesdaddee. I would make sure that when you are disarming your system, you are first entering your code, then selecting Disarmed Mode. If you do this out of order, it will not work. This Help Center article here has some great information for this subject. I hope this helps!

I appreciate you trying to help, but is there any other way to shut the alarm off other than typing passcode and then selecting “disarm”? This response does not resolve my issue in having major lag in the keypads. Thanks anyway…

Hi @Gabesdaddee. There are a few ways to disarm your Ring Alarm system. You can use the Keypad, the Ring app or Voice Commands via Alexa. If you have any concerns about your Keypad, I would reach out to our support team for further guidance. Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

I’ve also had issues with bad delays from my keypads. I called support and they could see interference with the signal by my base station. (We turned off all the power and there was still interference so unfortunatly it looks like it’s something from my neighbours.)

I found that moving the base station next to the keypad solves the delays for one keypad, but at the cost of more isues with the others. (I still haven’t found a good combination of basestation and range externder placement to help solve it.)

Being able to add a base station near each keypad would solve this for me. I added a feature request for it:

1 Like

That’s a good idea. Sad that we have to do this. Thanks for your feedback.