Issues with Setting Up my Ring Doorbell Pro

I’m having issues with setting up my ring doorbell.

The story behind this goes: My doorbell was currently set up under my step fathers account and he shared it with me. Earlier this week it just stopped connecting to the WiFi. I let it go and noticed at some point it had reconnected itself.
A few more days passed and the same thing happened again only this time it hadn’t reconnected.

Being fed up with this issue, I tried all the trouble shooting methods but none of them worked.
I thought maybe the doorbell needed an update. Well the only issue with that is my step father isn’t around and won’t be around for awhile for him to update the doorbell. So I asked him to remove it from his account and I would try to set it up on my end, update it and hopefully have it up and running again.

This hasn’t been the case! I have tried just about everything the website has told me about trouble shooting but I keep having the same issue.

When setting up the doorbell you get to a part where it asks you to let the ring WiFi (the network the doorbell is giving off) to connect with your phone. I make sure the light is spinning and everything but it keeps saying that it is “unable to connect to Ring-123456”

I’m getting very frustrated with this thing and was wondering if someone could try to help me out.

What phone do you have?

iPhone 11 Pro Max
I’ve tried it on my phone, my iPad Pro and my friends Samsung S10e.

I know that some Android phones like Samsung have an advance setting in the wifi settings. There is a setting to switch to data if wifi can’t connect to the internet. It was an issue for me once and it helped me by turning it off. I don’t know much about Apple products though.