Issues logging into the Ring App for Android

We are aware of neighbors having an issue logging into the Ring app for Android. If you are experiencing this, please get the latest update from the Google Play Store or try re-installing the app on your device. If you still have questions, please connect with our support team here to chat with an agent during business hours. Feel free to comment below with any questions as well. Thank you!

1 Like

I have an Android S8. I stopped getting alerts after the 15 th of April. So, possibly the 16th after your update. I did update the app, logged out and back on. The app keeps telling me “no camera added.” The WiFi is fine. I can scan the code and try to setup again but it then tells me that this ring device is owned by ME! Dashboard shows zero new events, account settings have my name, email address and so on. When I hit history it says “no camera added.”

Hi @Dena72 ! I would confirm that you are using the email address + password that is tied to the account with the devices. Perhaps you created two accounts and this is the account that does not have the devices associated with it. Let me know what you find!

Hi someone hacked my email account last week and I cant set up my ring anymore. I made a new email address and it telling me to ask the Previous owner for access

Just left a email about my account being hacked. …wont let me access my ring anymore

FYI, this is how someone can hack your account…
Never, ever put your personal email on a public site. Even here.
With the information you just gave, I now know your email used for your account. By posting it here, I know you use it for your Ring account.
Now all a hacker would need is to run your email through stolen information to find passwords that were used by the email account in the past. So never put your email on anything public.
The only good thing is now Ring makes you use the 2 factor authentication. So, it’s not as easy anymore to hack anyone’s account. It’s possible but much harder. Hopefully Ring can help you regain access to your account.

1 Like

Hey @Biggz1021. Thank you for reaching out to the Community in regards to needing your email updated, but this will need to be taken care of by our support team here. Feel free to give them a chat or a call anytime!

@Eagle328 Thank you for taking our neighbors safety and security in mind during these times! We appreciate your due diligence in looking out for our Community members. :slight_smile:

I called the support multiple times for the past weeks.

They keep saying that we are aware of this issue for Android.

it works on Apple and PC

So seriously how long it’s going to take to fix this issue…

Otherwise why keep in investing on something that is not fixable by AMAZON RING…

1 Like

Cannot log into the app. Uninstalled/Reinstalled but get the error message “An error occurred trying to perform the operation . Please try again.”

I tried restarting the phone and get the same message. As an aside, it would be really nice to have a show button for the password. The tiny grey print is really hard to see.

The reason I am having issues with the app is that I reset the password because I was trying to figure out the protect plan subscription and had issues logging into this forum on my PC.

The reason I was on this forum is that I just bought the new keypad with the alarm buttons. I have had the protect plan for a year (it is ready for renewal soon) but keep it turned off due to false positives during initial setup.

If the monitoring is set to off, will those alarm buttons not work? If they do not work, can they be made to work if the protect plan is purchased but temporarily turned off? THX

Hey @Slinky2. Thank you for your feedback on your desire for a show password button. I will make sure to pass on this feedback to the appropriate teams for you. Are you still unable to log into your Ring app on your phone? If so, please try logging in with wifi off and only using mobile data, or vice versa if you were on mobile data before. In the event this still doesn’t work, please capture a screen shot of this error message when it pops up again and let me know what Android phone you are running this on and what OS your phone is on.

For the Alarm buttons, can you please let me know what you are referencing on that? Are you talking about the Panic Button?

1 Like

I turned off Wifi and logged in successfully. I turned Wifi back on and am still logged in so hopefully that will hold thank you.

The new keypad has the 3 buttons, circled in red, for police/fire/medic. I have the protect plan but have it turned off due to problems with false alarms. I do not mind paying for it but would like to have these 3 buttons, the panic button product and any other direct request for emergency help go through even if the protect feature is turned off at the moment.

@Slinky2 Thanks so much for getting back to me and I’m glad you’re able to log in and stayed logged in now. Are you saying you have put yourself into Self Monitoring? Whilst in Self Monitoring, you will be unable to have any form of police, fire or medical dispatch to your residency as you have elected to be in Self Monitoring. If you wish to have these dispatches available to you, you’ll need to be in Professional Monitoring.

Some of these buttons will still have some function when in Self Monitoring, as the police and fire button will still set off the siren on your Ring Alarm, and the medical button won’t do anything. The siren will sound for 10 minutes, or until you disarm the system. Even if the siren is silenced after 10 minutes, the Ring Alarm will still be “alarming” until you Disarm it. Hope this help clear it up for you! :slight_smile:

My Samsung just got an OS security update, and I too lost access to the Ring app. It kept saying can’t figure out the location, and I check the app permissions, and it has the correct permissions.

I finally deleted the app and reinstalled, and then the error morphed into “Not able to login, try again.” Thankfully, I see that you disconnected WiFi and logged in successfully. I turned off WiFi and was then able to login after it prompted me for the six-digit code sent to my email. So THANK YOU!

I believe this is probably a bug in the way the Ring app handles two factor authentication or something related to that. It is infuriating that I wasted over an hour trying all kinds of things including resetting my Ring devices to try to gain access again. This is the most basic function. Can Ring at least acknowledge the bug?


Any chance of someone fixing this ? Anytime soon ?
I’ve tried all else so it definitely needs to get fixed soon

Please let me know

Hi @caolfin! Do you receive an error message of any sort when attempting to log in? As you are using android, please ensure there are no apps installed that might conflict with the Ring app. If you have not already, removing and reinstalling the Ring app is a great way to ensure it is up to date and optimally integrated with your mobile device. I hope this helps! :slight_smile:

And… if it still doesn’t work, then what? I am also unable to login from a PC on the Ring Website. The website says wrong password, the Android App says an error occurred trying to perform operation (after updating, clearing cache and data, uninstalling and reinstailling) and I’ve already reset the password twice JUST TO MAKE SURE. I even just used my newest password (not working on app or website) to login and setup a user name for this forum!!! What is Ring’s PROBLEM!? I had no issues an hour ago on my phone. I tried on the website, and the “wrong password” message popped up. I went into the app to confirm. Couldn’t see the freaking password for itself, just the reset option. So then i reset it. It then logged me out of the app as well. Tried to re-login with the new password(s) and now I’m stuck out of the Android App and the website. I have an active Ring Doorbell Camera, that is no longer accessible to me!!! This seems like a royal waste of money!

1 Like

Hi @MOSYED. For this situation, it may be best to contact our support team. Once you’ve made contact, they’ll be able to work with our access team to see why you’re unable to login and get this resolved for you. Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

Am having this issue today with iOS and Android devices.

Cannot login to app via mobile devices when they are connected to WiFi ('An error occur trying to perform the operation. Try again later. )
Cannot login to Windows apps on PC (error code 0x80131500 - ‘Something went wrong’).

What’s going on Ring? Sidewalk rollout being stimied?

All of a sudden my app is not logging in and got a message, something about my password was compromised within the internet and asked me to change. Changed, and still cannot log back in. Called CS and after over an hour waiting on a call the call is dropped and no call back. I called again and after over another hour got a call back from the same person who knew nothing the first time and dropped my call. Second call was a total waste of about 40 minutes for her to tell me I needed to try again tomorrow because maybe I was locked out. “Maybe?” I decided to set up another account with my google email address and when I scan the ring, it says I’m not the owner. Totally not happy with CS or my ring and just want someone to help. Frustrated with foreign CS and after a total of three hours still not having my ring working.

Hi @LarryB3. I would try to login across different platforms (tablet, phone, laptop) to see if this produces the same results. I would also try this on and off wifi. If you get the same results, try changing your password and attempting this again. Lastly, if you are unable to login, you can contact our support team to change the email address to a different email account. If you call into our support team and the representative you speak with is not offering productive troubleshooting and/or feel you would be assisted better with someone else, feel free to ask for a transfer to a supervisor that you can communicate with to reach a speedy resolution, or another representative-if available. :smiley: