Invalid credentials when logging into iOS app

When attempting to login to the Ring app for iOS, I get an “invalid credentials” error message. I can login to the website with the same credentials so there’s nothing wrong with them. I’ve deleted the app, restarted my device, reinstalled the app, and I still get the same error.

Sorry to hear about this @thalman. This should not be happening. Please ensure there is not an extra space being added in the password or username field when initiating sign in. I recommend also disabling VPN if there is one enabled. Try also, logging in while your phone is using cell data only, as well as on wifi only, to see if it might be connection related. Feel free to let us know how this goes! :slight_smile:

Ran into problems with loading dashboard on iPhone app. Tried to get live view on doorbell could not connect. Did speed test on network, speed was good. Uninstalled Reinstalled iPhone app and now I get invalid credentials logging in. I can login fine on the ring.com website. Reset the password many times and still was able to use password on the main website, but the iPhone app still gets invalid credentials. I had uninstalled the app, hard reset iPhone and reinstalled. No luck. Can it get passed login screen.

I set cellular off to make sure I was on wifi, no luck. Any ideas?

In the App Store there is an app called Rapid Ring made by Ring. I installed that and tried logging in, but could not login with my credentials either. Thanks in advance!

I’ve tried all that. Nothing works. I’ve reset my password a half dozen times with different passwords trying to get something that will work. They all work fine when logging into the website but not into the app.

Hi neighbors! If you’ve confirmed that no VPN is enabled on these devices, and that the password is correct when logging into your account at Ring.com, from a web browser, then your Ring app should also be logging in. I recommend also checking that your keyboard or device settings are not auto inserting a space before, after, or anywhere in your password.

As we value your security and privacy, if this concern persists, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

Very unhappy and a huge waste of my day trying to login into my IPHONE 6 ring app. I am able to login using my husband login on my phone but when i use mine, because he has added me to the main account as a shared user it does not let me login. I created an account can login in online, i have no VPN I read everything, i uninstalled the app and still nothing works. It make no sense at all, and above all the time wasted on nothing, makes me want to return this device. Plus, there is no way to get out of the account verfication section without having to shut dowm my phone. I am stuck in it until I verify the code, could use a back button. if i close the app and open it stays on the verify section. There is no reason why an app like this should not work. Password I use is right…I have double checked everything. Would like some help. Thank you