Initial setup for doorbell issue

Hi. Just got a 2nd gen ring doorbell and I’m having issues adding it as a device. It fails to connect to my wifi network. It will connect to a hotspot not even to a guest network I created. Anyone else have this issue?

My ring door video door bell will not connect to my centurylink internet

I am having the same issue. Were you able to figure this out?

@Strujillo5683 and @JuanH20 ,

I would re-try the setup procedures, but this time I would use a hard “Factory Reset” by pressing and Holding down the reset button for more than 20-seconds. Then let it reboot back up and it will re-enter the setup over again. A Factory Reset returns it back to the firmware that is had coming out of the box, and cleans out anything or downloaded firmware that might have caused you issues the initial time you tried to set it up. It’s like starting over again fresh and clean.

If this still doesn’t clear up your issues, I would telephone Ring Support for additional help and trouble-shooting assistance, and they can even look at both your accounts to determine what might be causing the issue:

Unfortunately, due to the Covid-19, their available hours have been changed also:


1 Like