Impossible to connect my Ring Video Doorbell (2nd generation)

A few weeks ago my Ring Video Doorbell (2nd generation) got disconnected from the wifi and since then I haven’t been able to reconnect it (even after reset, rebooting my wifi APs) after maybe 30 times where :

  • I tested from various places in my house
  • I’ve tried to uninstall/re-install the app
  • I’ve tried to create a new location
  • I’ve reset-ed the device

I’ve now the impression my doorbell is just e-waste, and Amazon.fr (where I bought it) just don’t care to help since it’s older than 2 years…

Hi @tanuki. You can also try these additional steps if your Doorbell is not connecting to your wifi:

  • Try completing the setup using a different device like a phone or tablet.

  • Disable any active VPNs on your phone and network.

We also have this Help Center article here that explains potential router settings that need to be changed for your Doorbell to connect. If it has connected to your wifi before, it is still a good idea to double check these settings in case something has changed. If you have tried these steps and are still having the same concern, give our support team a call at one of the numbers available here for further assistance. If you are outside of the US, please visit here to see how to contact support.

I tested all the ideas you provided and nothing works.

And it’s strange because it’s able to get an AP on the network but it’s still complaining about internet connection.

Hi @tanuki. You may need to adjust some settings on your phone. Go into your phone settings and make sure your Smart Network Switch or WiFi Assist is turned OFF. Additionally, try connecting your Doorbell to a WiFi hotspot. If it can connect to the WiFi hotspot, there may be an issue that your ISP has to address with your network. I hope this helps.