I cannot add new doorbell on my account

Hi since 3 days I try to add new doorbell in my account and stick up cam that never used (new in box) but bought 3 years ago. Each time I got the same error with my both devices.
For door bell left side white light is blinking and and tried hard reset etc… Still same issue. And finally I tried even with chime pro. But still same issue. Pls kindly help me.
Thank you

Hi @Bozayu12. You may have some restrictions on your router that do not allow the Ring devices to connect. Could you please check out our Ring Help Center Article here to review your ports and protocols and ensure your router is set up to allow the Ring devices to connect? After making these changes, let us know how the setup goes!

Hi Chelsea,
Thank you very much for your quick reply I will check all details but as I am using my account and plus plan since 3 years I use to use different products with same isp for exemple I still use another ring doorbell,Chime pro, 3 stick up cams, ring pro doorbell,flood light cam and some spotlight etc… So if it’s it’s with isp problem how can still use all my stuff?

Thank you

Best regards

Hi @Bozayu12! If you have other Ring deice working at that location and on your account, then this Video Doorbell should certainly setup. I recommend removing and reinstalling the app, or even trying the setup on another mobile device. Let us know any further observations you have or any error messages you receive during setup that might help us assist you further :slight_smile:

Hi Marley,
Believe I already tried all your suggestions. So deleted app and reinstall it. Tried with different devices,another iPhone and iPad. But no way.

So my problem is for ring doorbell is left led is blinking white for 2 ring doorbell and for stick up led is blinking white too. I changed router also tried with other networks and even with chime pro. Always same message no internet connection.

Pls help me because I need to install those devices.
Actually I am using plus plan and all my other devices is working correctly.

Thank you


Still no help and no solution… Can someone help me Pls?

Hi @Bozayu12. I’ve answered you on your other post about this same concern. If you are still having trouble, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.