I am a little lost and pulling my hair out!

Hi I have had a ring video doorbell gen 1 for years. After doing some renovations we broke the end of the cable that provides power straight into the back of the unit with the tape and a little plug (not bell wire connectors).

I cannot get my device back onto power. I have tried:

  1. Bearing back the wire and connecting the old power supply directly to the bell wire connectors (as the little connector snapped off) - no light!
  2. I bought a 24amp plug in adaptor from Amazon, compatible with Gen1 and connected. No light!
  3. I bought a Ring resistor and tried with that - no light!

The unit seems fine and charges ok.

Any ideas?

Many thanks.

Hi @Wyksey. Are you referring to a Ring Power Adapter that you had for your Video Doorbell? If so, you can find that on our website here which is compatible with the Video Doorbell Wired, Video Doorbell - 2020 Release, Video Doorbell, Video Doorbell 2, Video Doorbell 3, Video Doorbell 3 Plus, Video Doorbell 4, Video Doorbell Pro, and the Video Doorbell Pro 2. I know you bought an adapter from Amazon, but we can’t guarantee that any third party adapter will work properly with your Ring Doorbell.