How do I set motion settings to stop getting false alerts and stop missing motion events?

How do I need to set my motion settings so I stop missing motion events and stop false alerts?

So when nothing is moving I’m getting occassional notifications. I tested it by putting it in a perfectly still closed box and it still went off.

But, then alot of the time when things are moving for sure I dont always get a notification or recording. I tested it by standing and moving around in front of it and I got a notice half the time while testing it.

I currently have it set to pick up motion in the whole screen on the most sensitive setting and I have this issue on both doorbells (but one is way worse than the other). I understand why this may cause false alarms but I dont understand how I both miss events and get false alarms.

I also get pop up notifications that dont have an associated video recording so I dont know if theres an event or not. Even after waiting a while no recording appears. How do I turn on recording for all events that i get a notification for?