High failure rate with Ring 3 Solar Panel?

Originally, it seemed to work, the Ring 3 solar panel. It showed as ‘connected’ in the App and gave me a few percent increase per day. However, my main Ring 3 doorbell unit then became faulty (button press did not always trigger, faulty button I suspect), so I am in the process of returning it.

Since changing the Ring 3 doorbell unit, the Solar Panel does not charge at all. It is located on a south facing door, in direct/bright sunlight… but nothing at all power wise.

I have tested the panel terminals with a multimeter, whilst it shows 5.5V it generates zero (0) amps - so no power - this suggests the solar panel is faulty. So I’m going to return this now for a replacement to Amazon.

As I mentioned, it is located on a south facing door, in direct/bright sunlight, no clouds, at midday, with the panels visibly receiving sun… but nothing at all. Another small panel I have in the same location, as a test, has no problem generating power.

Bit annoying that I seem to have had a faulty Ring3 unit (faulty button) and now potentially the solar panel as well.

Hi, I just logged on to post the same problem with the Doorbell 3 solar charger and saw your post.

Mine also showed ‘Connected’ a few minutes after install and since then it’s been disconnected with the battery draining. I’ve seen some reviews on Amazon UK mentioning the same thing.

I purchased from Ring so will give their support a call tomorrow.

1 Like

Let me know how you get on - although from various other posts and being a cynic I don’t hold out much hope.

If you have a multimeter would be interesting to test the panel, support seem to have a habit of fobbing people off from what I can gather.

The Ring3 unit itself does feel a little cheap to me, various reports of the plastic cracking after a period of time. Am tempted to just return the lot and cut my losses, at least returns with Amazon are easy.

I see on Amazon it now reports:

Currently unavailable
We don’t know when or if this item will be back in stock

Wonder if they just sold out, or again the cynic in me, had a bunch of returns and/or replacement shipping.

Spoke with support earlier. He asked to remove the doorbell from the solar unit and perform a factory reset (hold on to orange button for 20 seconds) and re-add to my Ring account. So far it’s still showing connection as ‘Established’. Will keep an eye on the status and update in a few days.

I’ve noticed 1-2 weeks ago that Amazon UK had it listed as ‘not sure if this will be back in stock’ but then was available to order a few days later.

1 Like

Hey there, thanks for the reply.

Just tried the same - removed the doorbell, factory reset, set it all up, before connecting the solar panel again as the final step after set-up with it removed. No joy, unfortunately.

Suspect we may have different issues, yours sounds more firmware related, but I’m still getting no power reading when using my multimeter and it’s in a bright/full sunlight right now.

Replacement from Amazon should hopefully arrive tomorrow.

1 Like

It’s great seeing neighbors work together! Excellent recommendations @F1N1. A reset can certainly help if the device is not reading or operating a component as intended.

, It sounds like you’ve covered a great many steps, in which you should’ve obtained the intended functionality by now. A replacement should do the trick! Feel free to let us know how it goes. :slight_smile:

@iMx hopefully the replacement works for you.

An update on mine - still all good a few days after the doorbell reset. Battery has either stayed at same level or increased by 1%.

Hey there,

Whilst I now get milliamps on the multimeter from the new panel - the old one still doesn’t register anything, even in the same location - the Ring App still refuses to believe it’s connected.

So now I don’t know if it’s a charging problem with the new Ring unit - this all seemed to start when swapping out the Ring unit, the original had no problem detecting it - or what.

Have disconnected, deleted, factory reset at least 4 more times this afternoon… no joy. Think me and Ring are ‘done’, probably going to return the lot, wasted enough time on this. :slight_smile:

Thanks for the replies anyway, wish you all the best with yours.

Thank you for all the great help you have offered this and other fellow neighbors in the Community, @F1N1. Could you please reach out to the Community Team at community@ring.com? We would love to ask you some questions and get your feedback directly as a valued member of the Community. :slight_smile:

HI Chelsea,

Sure I have just sent an email to that address :slight_smile:

If anyone else has the issue, also note the doorbell won’t start charging until the battery dips below 90%.

1 Like