Help !! Ring Doorbell won't pair with Alexa

My Ring Doorbell doesn’t pair with Alexa. My chimePro also isn’t recognized.

Sometimes I get a chime on my iPhone but no notification on my ECHO or my ORBI Voice.

I tried SKILLS with no success. I search for devices but nothing.

What am I missing?

Hi @sandy641. Have you tried resetting your Doorbell by holding down the setup button for at least 20 seconds? Give that a try, and then set it back up in the Ring App with the steps under Set Up a Device. You’ll also want to disable and re-enable the Ring skill in the Alexa App after completing this new setup. Should this still not be working properly, please give our support team a call at one of the numbers available here. They can take a deeper look into this for you. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. :slight_smile: