Have Echo Show 8 Show Video on Ring Doorbell motion

Folks,

This has been driving me nuts and as I read the posts on in your community forum, it seems that many people are having this exact same problem.

I have added the routine to two (of 3) of my Echo Shows for it to automatically show who’s at my front door when it detects motion. But when it does detect motion the Echo Show just says “OK” and nothing else happens. Sometimes it will show that it’s "waiting for Ring.com but nothing happens after that. Sometimes it says, “Something went wrong”. If I then ask the Echo Show to “Show Front Door” it works quickly and flawlessly.

It seems that these two devices were made for each other and that it should be easy to to set up. But this seems to not be the case. I, and many others all thought the same thing; that these devices would work well together.

I have a Mesh network. The wireless speed tested right at the the doorbell is:
Download = 66.85
Upload = 4.22
Ping = 52
RSSI = 48
Firmware it up to date

I don’t have any Routines setup for my Echo (Alexa) and I get the notifications from my doorbell that someone is there, and the video is displayed on the Echo.
Maybe disable or delete the routines. Then go into the Devices in Alexa and select the doorbell camera. Then select Settings (gear icon) and turn on the slider for Doorbell Press Announcements.

1 Like

I disabled the routines and made sure that my motion and doorbell press announcements were activated, . Now my Echo Show 8 notifies me that there’s motion at my front door but does not show any video.
But thanks for the reply! Much appreciated!

Hi @Macster. I know you just tried disabling the routine to see if that would work, but could you try setting up a routine again using the steps below?

-Open Alexa app
-Tap on More (bottom right corner)
-Select ROUTINES
-Tap the + (upper right corner)
-Tap on ENTER ROUTINE NAME, name your routine, and tap Next (upper right corner)
-Tap WHEN THIS HAPPENS, select Smart Home, locate your Ring device and tap on it
-Tap on MOTION
-Tap on toggle (button) for DETECTED, tap Next (upper right corner)
-Tap ADD ACTION, scroll down and locate and tap on CUSTOM
-Type in: Show Front Door Camera (substitute “Front Door” for your actual camera’s name)
-Tap Next (upper right corner)
-Tap CHOOSE DEVICE (select the Alexa device w/ a screen that will auto start video when motion is detected)
-Tap Save (upper right corner)

Let me know if these steps work after trying them. If it doesn’t, you can find more troubleshooting steps for when your Ring and Alexa features stop working in our Help Center Article here. That article will run through disabling and re-enabling the Ring skill in the Alexa app, which is a good basic troubleshooting step to try as well.

Thanks so much for the reply Caitlyn! It is much appreciated!
I have done the above and when:

It does detect motion the Echo Show just says “OK” and nothing else happens. Sometimes it will show that it’s "waiting for Ring.com but nothing happens after that. Sometimes it says, “Something went wrong” or, “I don’t know what went wrong”. If I then ask the Echo Show to “Show Front Door” it works quickly and flawlessly.

Any help is of course appreciated!