Full WiFi Connection Stick Up Cam Doesn’t Work

I have 2 stock up cams at home. Both work awesome. So I got 2 more for our vacation spot, that has WiFi, and I can’t get them to work. I have set them up, and then reset them and did it again. Both have excellent WiFi signal. But when it says they are ready to use, I go to “live view”, and nothing comes up. I get “streaming error”. So I try to reconnect and nothing. Also, motion doesn’t turn them on either. I had a support person on messenger, and she tried to help, but still no work. Even though EVERYTHING else says it should.

Any ideas?? Any help would be RAD!!

These are some of the screen shots I took for the online support.

Sorry to hear about that @Stovebolt! To start, if you are able to live view your home Stick Up Cams from the vacation location, this will rule out cellular coverage. Keep in mind, when setting up new devices, there can often be an update before it is fully ready to use.

The next things I recommend checking are the device RSSI and the wifi speeds at the location to ensure they are sufficient to operate both Cams the same as your home. Let us know how this goes! :slight_smile:

1 Like

Hey Marley! Thanks for your reply!!

Turns out after some further investigation the person who runs the resort has somehow blocked cameras from working. I don’t know how, but it’s true. As a matter of fact, while I was there on their WiFi I tried to access my cams at home and couldn’t do it. Shut off WiFi and was able to get them to work no problem.

At least I can use the cameras at home, and when they get it together out at the lake, I’ll pick up a couple more for out there.

Again, thanks for your response! ?

1 Like

You an FYI. I’ve had places block video and Ring with it on wifi they supply. If you use a VPN you can get around these blocks very easy. I use Nord VPN but there are plenty of others. Some are free as well. Hope this helps in the future.

Suggestions on why our home wireless network would be blocking the videos?? I have been going through the “ringer” with Ring, Suddenlink, and Motorola trying to get ours to work. Ring is now saying we should just return the cameras and try new ones. I believe something is blocking because we connected the camera to a neighborhood Guest network and they recorded fine.

Suddenlink ISP says there is nothing in their system which would block.

Our modem/router is Motorola and they say with the revisions made (port forwarding, turning off or disabling firewalls) it should work.

Guess I am venting but sure would like to find the answer…


I am having the same problem with the live view and “streaming error” …did you ever find a solution? The wifi connection is strong, the motion works and the doorbell works but when i go to see who is at the door, I get the “streaming error” message and cannot see. I can go back once the activity is availble but obviously that is too late!

Yah, so I found out that whoever the administrator is at our resort has the WiFi set up so that there isn’t any file sharing. So the cameras hooked up to the I WiFi, but they wouldn’t sent the info. As a matter of fact, I couldn’t even see my house ones on their WiFi. I had to shut off my WiFi and use data. Data did’t work on the resort cameras either because they were still using the WiFi.
So I just brought them home.

We did not find a solution. Ring wanted us to return the cameras and try new ones. But we took them to a different house and they work great. It must be something to do with the WiFi or modem although we thoroughly tried to troubleshoot it. We may buy a new WiFi modem and see if it works.

Did you check your modem settings? That may be all the problem right there. I don’t know how to change them, but someone at the place your internet server tech should know.

Sure did. Was on the phone with internet provider and when they wouldn’t help, I spoke with Motorola (brand of modem) numerous times. Nothing helped and I tried everything they suggested.

Re: Full WiFi Connection Stick Up Cam Doesn’t Work

Re: Full WiFi Connection Stick Up Cam Doesn’t Work