Force Firmware to Update on Ring Video Doorbell Pro

Same here. My Doorbell Pro was ‘Up to Date’ until 2 days ago, and has shown 2.1.01005 ever since then. Same with my wired Stickup Cam, sitting on 2.1.01005. Both cameras have had multiple motion events and live views, but have not yet auto-updated. First noticed both cameras no longer showed “Up to Date” on evening of 12-10, so it could have been longer… that’s just when I noticed.

Still at ‘Up to date’ here, and I have no idea which version that is :slight_smile:
It would be nice if there was a support/firmware page so we could check en read what was fixed & improved, because today … I don’t know if my version ‘Up to date’ contains the security fix…

I have the exact same problem as you BoyGeenYuss. One showing 2.1.xxxx and the other showing 1.16.xxxx and having problem with SnapShot Capture Function on that one.

I installed both of mine the same day. The one with the higher firmware was installed first without a problem and updated during the process.
I was on the phone with support. We couldn’t get the lower firmware bell to update. They’re sending a replacement.

Neither my Doorbell Pro or Wired Stickup Cam have updated–both are still sitting on v. **2.1.01005 ** since at least 12-10. (I have a friend that lives nearby and his Stickup Cam also shows this same version, and has not updated).

I’m not having any problems with either device, so for now, I’m not pursuing why neither camera is auto-updating as it should.

Agreed, it would be nice if Ring provided a list of firmware versions, changes within, and dates. I’d like to see them be as transparent about their firmware as they are about the Ring System status.

2 Likes

Anyone else’s firmware update yet?

Over a week later, and my Doorbell Pro and Stickup Cam are still both sitting on v. 2.1.01005.

I have the same problem. My rear door camera says “up to date” but the doorbell had the firmware listed, which according to the doc means that firmware is NOT up to date. After 2 hours on the phone with support, it turns out that my firmware was in fact up to date, it just didn’t say so in the app (like it is supposed to say).

I reinstalled the app per support’s advice, but it still shows the number, not “up to date.”

Clearly a bug in the app. How am I supposed to know if my doorbell firmware is up to date? Call tech support every month?

Can’t find any way to report a bug on the app.

I wouldn’t buy that story. Their online chat Support told me the same nonsense. Then I spoke to a US Support Agent to troubleshoot the Snapshot Capture feature which wasn’t working, he told me my Firmware was outdated and was unable to update after multiple Forced attempts. Ultimately he sent me a replacement unit and after installing that one it updated and everything works great now. I think you need atleast 2.1.01005 to have that feature work.

I am having the same issue. After a week and a very long support call I was told to take it back. Took it back, the new one has been in place for a week and no update. Spoke to support and they are pretty useless. Not sure how many times a person can go through setup. They wanted me to take this one back, they also blamed my wifi (Eeros)., They blamed my ISP…not enough bandwidth which is 300down and 24up. Funny that the connection is good enough for 3 laptops, 2 desktops, 4 phones, 3 firesticks, a camera system, 2 smart TVs but not for a doorbell.
Support is trained to blame the customers side of things and leave it at that.
My neighbor installed in about 2 weeks before me and it has updated…

I’m just paying attention to this whole firmware thing today for the first time. As of right now, my Video Doorbell Pro is at 2.1.01005, so I assume that it’s been at least 20 days since Ring last updated my device if I’m going by others’ responses.

Same issue here. Been at 2…005 for a few weeks now on my two doorbell pros. At minimum Ring should publish firmware update numbers and information like other companies do. I haven’t tried calling support yet. I tried support on another issue I was having and they weren’t much help.

Hey everyone, for what it’s worth, I spoke to support earlier this week about something unrelated and she advised, despite showing the version number, my DB Pro and Wired SuC are both up to date on v. **2.1.01005. ** I realize this contradicts what’s stated on the Ring site, that if it doesn’t say Up to Date, it’s not, but that’s what I was told…

Still, no issues with either device, and Snapshot Capture finally appeared on NYE out of nowhere for all 4 of my cameras.

9 days later and no change. Ring pro still sitting at 1.16. Not sure if it even matters but the inconsistencies regarding firmwares is mind blowing

Same issue here with ring pro, thanks for all your posts. Sounds like I probably have the latest version already and its a glitch in the way the software is rendering it e.g. maybe it thinks theres an update but there isn’t; maybe it will resolve next time they release one etc.

Would be nice if this was posted by Ring themselves somewhere as something we don’t need to worry about. I was just searching to see if my firmware was latest so a change log somewhere would be nice too.

The technical support for this product has got to be embarrasing for Google. I’ve spent 47 years in the tech industry, including some time at Google, and I’ve never seen anything like this. I just received a new Ring Pro and the audio is still clipping. If I was a senior manager in product development there would be some individuals who would have lost their job by now. Ring, please stop covering up product problems and get your act together. Not all customers are technically incompetent and are now very tired of tier-1 tech support wasting our time!

Ring is an Amazon device not a Google. Google owns Nest devices.

Just spent an hour on the phone with support on this Firmware issue. I think I got BRUSHED OFF :frowning: He said someone would look into it and then update it later for me? My RING doorbell is only working about half correctly and I feel this Firmware update may fix all my issues.

I’m not feeling good about RING

I’m having the same exact issue as @boygeenyuss with same firmware Version 1.16.00272 that won’t update. Snapshot feature isn’t working. Ring support via email has been no help…not sure how many more times I can take them suggesting to reinstall the device and app. Have you had any luck? It sounds like I need to push for a replacement device.

I have not contacted support since my last call with them. There has been no change. I’m not willing to waste more of my time.
I did get an email from them asking if everything is going well since we last spoke. If anything they are funny.

I’ve had the same issue, purchased new last week and can’t get the firmware to update. I’ve been on the phone and emailing with Tech Support over the last couple of days. They keep saying the same thing about reinstalling, signing out, etc. but nothing ever changes. I’m to the point where I’m ready return the device and go in a different direction. Support has been brutal!