Floodlight camera not working

I have a Ring Floodlight. I took it down and stores it in a box when our cottage was rebuilt. I hooked it back up. The floodlights turn on. The camera has six small red lights at the top, but I can’t get the bottom light to flash so I can connect the camera. Is there something I can try?

Hey @Karen7. If the Floodlight Cam doesn’t appear to be going into setup mode, I’d suggest performing a reset before attempting to walk through a new setup. To reset the Floodlight Cam, you’ll want to hold down the setup button on the top for at least 20 seconds. Once that’s done, try to set it up in the Ring App again by following the steps under Set Up a Device. Let me know how that works for you! :slight_smile:

I have tried to reset multiple times. I uninstalled and reinstalled the camera. Nothing seems to be working. Any other tips are appreciated.


@Karen7 Thank you for letting me know how that worked for you. In this case, you’ll want to reach out to our support team at one of the numbers availablehere. They’ll be able to take a closer look at your device and provide more advanced troubleshooting steps for you. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19here to see how to contact support.

Thank you!

1 Like