Floodlight Camera: Flickering Purple Video last seen, now Live Streaming fails

Hi,

I purchased a RING spotlight wired camera on the 9th April and installed it shortly after which has been working fine until the last recorded video on the 18th June that shows lots of purple flickering across the screen. From that point I haven’t been able to connect via Live Streaming, I just get ‘Stream Error’.

Since this point, the lights are continuously coming on/off, and during the evening / night, this triggers an alert on another CCTV system that is in the same area and I’m receiving email notifications every 5-10 seconds so you can imagine it’s relates to a lot of false alerts to look through in the morning.

I’ve tried switching of the power, removing the device from the app, reducing / turning off all functionality on this camera not only to try and stop the lights from coming on, but also to establish connection back to the camera. Also I’ve checked the device heath and all is good.

I still cannot connect to the camera.

Can anybody please advise action to take as I haven’t had this camera long?

Thanks
Wayne

Hi @Mugsy. You’ve definitely done a few of the troubleshooting steps I would have suggested, so you’re off to a good start. Since the Camera still isn’t working properly after what you’ve tried, I would recommend fully resetting it before adding it back into the Ring App. You can reset the Camera by holding down the setup button for at least 20 seconds. Once the reset is complete, use the steps under Set Up a Device to get it back up and running in the Ring App.

If that doesn’t do the trick for the errors you’re experiencing, our support team can help take a deeper look into this. You can give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. :slight_smile:

1 Like

Hi, This has made no difference, I still get ‘Streaming Error’ even when I connect the phone to the same network as the camera. The App is connecting to the camera as I can still manually switch on the light / siren. The device health is good and has the latest firmware.

Thanks
Wayne