Floodlight cam - fast flash on bottom light

Recently installed a floodlight cam, which worked fine for a couple weeks, then dropped offline. Went to reconnect today, no luck.

1 - hit reset button. No response.
2 - Held reset button for 20 seconds and released. No response.
3 - cycled power to unit. Fast and weak flash from bottom LED (not the floodlights). No voice prompting for setup, floodlights not turned on.
4 - Tried connection process, gets to the “join Ring network XXXX” but then fails that step.

Have several other Ring cameras here; they are all working fine. Do I have a failed camera or ?

Thanks!

Hi there, @xarkon! It certainly looks like you’ve covered all the right steps here. Resetting and power cycling was a great call. If that did not work, this may require a more in-depth look from our support team. Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.