First Generation Sensor-Critical Connection Error and Cannot Remove

Two of my first-generation contact sensors stopped working. I suspected a dead battery, but since the device did not register on the system, I could not determine the battery status. First I tried resetting, then removing and re-adding, but nothing worked. Then I tried a new battery and added the device back, and all seemed to be OK until a few days later when I noticed it was returning a “critical connection error” message in the app.

I read one of the posts on the subject here and tried everything – resetting, removing, etc. The app will not allow me to remove the device. It fails every time I try (“we had problems communicating with your device”) – both before resetting and after. This is very frustrating. How can I get these devices up and running again?

Can you move your alarm’s base station closer to the devices and then try resetting/reconnecting/etc? Maybe they are too far for a good consistent connection to be maintained.

Hi @JSSGV1. As @SolarEclipse suggested, you may want to try bringing the Base Station closer to the Contact Sensors before trying to set them back up again, as they may be too far from the Base Station to maintain a stable connection. If that still doesn’t work, you can follow up with our support team at one of the numbers available here so they can take a closer look. If you are outside of the US, please visit here to see how to contact support.