First Alert Combo Alarm 2nd Gen - Will not connect

I purchased 5 of the 1st Alert combo CO2/Smoke detectors from the Ring web site two weeks ago.

I have been able to successfully install one. The other 4 refuse to connect to my network.

All are within 20 feet of either the base station, or a range extender (and other sensors, such as motion detectors or contact sensors, are likewise in the vicinity and are working.) I have attempted to set them up within 10 feet of my base station w/ no luck.

When I attempt to add these 4, I get the point of scanning the QR code and moving to the next page where I’m told to “Slide open the tray, insert batteries, and push in the tray”. Of course, I have done this. The alarm will chirp, but then absolutely nothing will happen on the screen. I can sit for hours on that screen and it will never advance (I know, I actually left it overnight at one point when I went to bed).

If I “Skip Device Setup” and then return to Devices, I see the Detectors with a “Waiting to connect to a Network” status.

I have tried removing the detectors and re-adding with no success. I have done the “remove batteries, re-insert batteries, hold test button down and then insert battery tray, count to 3 and then release test button” button process to ‘reset’ the alarm before attempting to re-add it again, with no success.

In an older thread on this topic, there was the mention of attempting to do a manual add using the “Works With Ring” option rather than selecting an alarm when adding the device. This actually got me a little further… When I use this option, if I do the “test button reset” process while attempting to add a device, the Ring app will “see” the device and attempt to add it, but will then abort with a “Device Security Error - The device added has an incorrect security configuration - Remove the device and try again”.

I tried leaving the batteries out of the alarm overnight in case they have something stored somewhere, no difference. (Unless there’s some form of a hard-reset process that will wipe out anything they may happen to have stored.)

I’m at my wit’s end with these. I have $160 worth of bricks and nothing I do seems to work.

Any thoughts from anyone?