Firmware Updates Appear to be the main issue on MOST questions.

I purchased a two pack of floodlight cams from Home Depot on Black Friday (online). I installed one over my garage (where there was no existing light) and one replacing the outside light on our patio. I installed the back yard patio one first. This floodlight cam worked as expected except that the speaker was defective. When I powered it up for the first time, I just heard a garbled mumbling that was telling me it was in setup mode. Even with the mumbling, I was able to get it set up and working. When I decided to test the siren a few days later, I discovered that it used the same speaker as the setup and therefore the siren was just static. I contacted Ring and they shipped me a replacement which took a little over a week (because of the holidays). This unit updated the firmware without issue and I was able to use the timeline and the time lapse function without issue.

 Then I installed the floodlight over the garage. the installation went as expected and when I powered it up for the first time I would actually understand what it was telling me. The first night, the floodlights kept turning themselves on no matter how many times I turned them off.  I made the light zone very tiny and finally just turned the three light zones off completely.  The camera still functioned well enough with the lights turned off. It would still record when there was motion detected and the timeline and live view worked correctly. The firmware updated and showed "up to date" under Device Health. It is possible that the problem with the floodlight turning on repeatedly may have been corrected with the firmware update so I will turn the three zones back on tonight when it gets dark and hope for the best.

 Then came the time to install the replacement floodlight in the back yard. I switched the two out and powered it up seeing immediately that the speaker was good.  The motion detection worked properly, live view functions, but there is no time lapse function on the timeline. The firmware is stuck on 1.16.00273 and will not update after three days.  I spent over an hour on live chat with a very nice young man. He sent my issue to the Advance Technical Team but they were not successful in getting my unit to update.  He said I will receive an email when they figured out the issue but, after reading a lot of these messages, I am not very sure that I will be hearing back from them.

 So, I have installed a total of three units. One with a bad speaker, one that had cursed and possessed floodlights, and one that will not update its firmware.  My real question is this: Why is there no way to force a firmware update on these products? Either technical support or the consumer (through the app) should be able to instruct these products to upgrade their firmware when it is not functioning the way it is supposed to.  At least I have a Ring Video Doorbell 2 that has been working properly for over a year (knock on wood). I am hopeful that these firmware issues on the Floodlight Cameras will be addressed correctly and SOON.

“I am hopeful that these firmware issues on the Floodlight Cameras will be addressed correctly and SOON.”

UNfortunately, many owners have been hoping for a fix since September, which is the earliest date I can find a thread on this problem. So Ring has known about the problem, failed to fix it, and continues to sell defective cameras.

They seemed to have fixed the issue. I powered cycled my cameras yesterday and the firware updated to the latest. I’ve verified that Snapshot capture and Color Night Vision are now working; and the floodlights no longer turn on every 30 minutes.

CrazyCat, I followed your advice and power cycled my spotlight cam and it did, in fact, finally update the firmware and appears to be working properly.

 On the other hand, my other spotlight cam in the front yard is still showing "up to date" on the firmware but the light still turns on randomly as if it is possessed by demons.  I was, again, forced to turn the light zones all off.  I can manually turn on the spotlight but can't have it turn on by motion detection.

 Thanks again for your response.