Everything works on my Floodlight Cam *except* LIve View/Video Recording

So, this one has me stumped… I have 9 various Ring cameras around my house (don’t ask… girlfriend is just paranoid). We had to replace one of our floodlight cams after a roof leak flooded it awhile ago. I’ve had this gen 1 Flood light cam sitting on a shelf for over a year, and finally got around to replacing it this past weekend. The install went pretty smoothly, I thought. The app sees the new camera just fine. I started getting motion alerts almost immediately. When I look at my device list, I see the camera, and it updates the thumbnail screenshot immediately. When I edit the motion zones, it grabs a new still image to use to define the zones. Everything seems to be working fine… except it won’t record video or display a live view. It hasn’t recorded a single video since I installed it, even though the camera appears to be working.

Obviously, the first thing I checked was it’s wifi signal. It has the cleanest signal of any camera in my house. There’s a wifi access point less than 10 feet from it, on the other side of a window. The RSSI value is -24, so there’s no chance it’s a network issue. I thought maybe the firmware got corrupted when it was upgrading itself, so I did a factory reset (held the setup button down for 30+ seconds), and reinstalled it in the app, but that didn’t work either. I even tried the Rapid Ring app, to see if that was any different. Oddly enough, it did give me a different error message, about that camera being blocked by my wifi network… but if that were true, why do all the other features work, not to mention all of the other Ring products? Anyway, I’m running out of ideas… my next step is to remove the camera from the junction box and make sure none of the bundled wires inside the housing came loose as I was installing it. But before I go through that headache, I figured I’d ask here first…

Any and all help is appreciated.

1 Like

Try swapping it in the location of a camera that does work if possible. That would eliminate the possibility that it is location specific for some odd reason.

1 Like

Interesting idea, but I know that location is suitable… as I said, I had the same model Ring Floodlight cam there before. The old one had water damage to it, so I had to replace it entirely. Roof is fixed, the area is safe again, and the new camera is in exactly the same place the old one was.

1 Like

@RAkers

The ONLY thing I can think of here is, do you have Modes enabled for your cameras? Wondering if you have that new cam set to disable Live View and NOT record motion in all 3 modes if you have Modes enabled. Thing is, if this were the case, you’d be presented with an in-app message when attempting Live View with “Live View not available in this mode…” or something similar.

Maybe if you have camera Modes enabled, try turning that feature off and re-check. Or, try enabling it (at least temporarily) if you have it off.

Finally, if you have a mesh WiFi network, is there any other Ring devices on the same access point as the problem camera? If the problem cam is connected to a access point, can you try powering down that AP to force the cam to connect to the next node? (again, this all assumes you’re running a mesh network). Also try logging into your router and checking the DHCP pool–is it possible you’re out of IP addresses? (unlikely unless you have a LOT of wireless devices). Maybe try issuing a static IP for the problem cam just to try it…

I wouldn’t bother removing the camera from the junction box. It really sounds like you’ve covered all bases here. That Rapid Ring error is sort of generic from my experience whereas the underlying problem can be multiple different things that are not your network. If all your other cameras are on the same network and are functioning fine, nothing is being blocked by your network.

I’d advise calling Ring or replacing the cam. Based on your troubleshooting, I’m going to guess the firmware corrupted something, or the camera is just defective. Maybe and hopefully something I typed above helps, but I’d be surprised if it does.

Good luck regardless!

1 Like

Thanks for the reply. I am on a mesh network, but there are other cameras on the same node. However, just in case this could be the problem, I bought an entirely new node and set it up 10 feet away from the camera. Same problem on both nodes. Still pictures are coming in, but live view and video recording isn’t. I thought maybe one of the wires that power the camera came loose, and that’s why it’s not recording video, but that doesn’t make sense either, unless there’s a separate camera that takes stills. That’s why I thought I might take it off the junction box. I’ll have to remove it away, if the unit is bad. I checked the mode settings, but that’s not the issue either. Everything is using the default modes, and live view is enabled on everything.

Honestly, as much money as I’ve spent on Ring products, I’m not really impressed… I’ve got 3 flood cams that I can’t turn the lights on because they just flicker and strobe now. I’ve got a floodlight cam that’s got a pink/purple image (looks like the green sensor is blown, I’m only getting reds and blue colors), and my front door camera doesn’t register when delivery guys walk right up the front walk and drop off packages. As expensive as all this is, I really expected better…

1 Like

First off as someone that has 7 ring devices and 4 cameras from another manufacturer, it’s not paranoia it’s enthusiasm.
As far as live view not connecting, if you are attempting on Android, this is an ongoing issue either in the firmware or software of the app, shut off data on your cell phone then attempt to do live view, it should be functional if you are connected to a Wi-Fi network, if data is necessary, use rapid ring until the issue is corrected.
This is an ongoing issue that I’ve been going through with my new ring plus camera, all other cameras are not affected and work perfectly.