Error loading Alarm system history

I have Ring Alarm system set up 9 days ago and it has been working fine until yesterday. I added two Z-Wave smoke & CO alarms from First Alert to the system yesterday. On Android app, when I tried to view event history of smoke alarm of either devices, it shows “error loading alarm system history” with details “we’re unable to locate any history activity at this time. please check your conneciton and try again.”. Oddly, I can view event history of CO alarm normally. Both smoke alarms of both units have the same issue. Both CO alarms of both units work fine. When viewing all alarm event history from dashboard, it shows events normally, including events from smoke alarms. But the same error occurs when I scroll down to view more. I’d say about no more than 100 event entries can be viewed. The error occurs if I further scroll down.

I had tried to restarted base station. tried to uninstalled/reinstalled the app. None of them work. Same issue on my wife’s Android phone. It’s working fine on browser I can view all history and history of individual devices with no issue at all.

My phone is Sony Xperia XZ2. My wife’s phone is T-Mobile Samsung Galaxy S9+. Both are on latest OS and updates available.

I also have a Ring video doorbell 2 which is working fine in the same app.

Please help me resolve the issue.

12/23/2019 update

The issue went away by itself. Probably the recent app update fixed this.

Did you clear the app data & cache before uninstalling the Ring App?

I did that before uninstalling/installing Ring app.

I’m having this exact issue. I called ring support and confirmed on my end it is fine on iOS and from a PC, only has the issue with Andriod. Also occurs on my Wife’s Pixel 2. What phone do you have? May be a firmware issue that is not compatible with Andriod models…

Sony Xperia XZ2 and Samsung Galaxy S9 plus.