Eero Mesh Wifi incompatibility

It seems to me that there is a compatibility issue with newer Eero systems.

I have a new Eero 6 mesh Wi-Fi that my cameras will not connect to (Indoor Cam and Floodlight camera). Both cameras do connect to my old routers (an AT&T wifi modem/router and a NETGEAR PowerLINE WiFi 1000).

I have Even tried disabling the 5ghz band on my Eero system and it still fails to connect and claims my router is too far away even if I place my Eero 6 extender within inches of my cameras.

The odd thing is that my battery powered Video Doorbell (1st gen) has no issues connecting to the Eero6 mesh Wi-fi.

Any suggestions on how to fix this? I contacted Ring support and have a Chime Pro on the way but even in the FAQ of the Chime Pro page (Ring Chime Pro | Doorbell and Camera Accessories | Ring) it indicates that the Eero mesh wifi should work. Also, I have seen people claiming they are having issues even with their Chime Pro’s connections to the Eero mesh WiFi. So…. Whats the solution to make Amazon’s Eero Mesh WiFi work with all of Amazon’s Ring cameras?

I’ve been trying to find this out too. I have been on multiple forums and looked back to discussions to 2019 with alot of people having problems with Ring and mesh systems.

There have been huge discussions on this with people still having problems yet Ring sells Eero. I wanted to upgrade to a mesh system but after reading so many people having problems, Ring cams and doorbells getting bricked and tech support not coming out with a definite fix, I’ll just upgrade to a regular router or get rid of the video doorbell and stick up cams.

I use eero Pro and eero 6 devices in my house and my Ring cameras connect perfectly to both Pro and 6 access points.


Okay, so I have some helpful tips here as I was experiencing Eero 6 connectivity troubles with my new Ring cameras on setup. First, my network name had a special character in it, namely an apostrophe, I created a guest network with a simple name, and disabled the 5G network to the 2.4GHz network for setup of the devices and it worked perfectly!! This help was due to calling the customer service number. The rep was super helpful and even sent me an email to contact him again should his suggestion not solve my problem. It was great to know if the remedy didn’t work, he was going to be able to pickup troubleshooting right where we left off, and in this situation continuity is so much better than having to start all over with a new person on the help desk. I didn’t have to try rebooting my modem and router, but that was next on the list of remedies. So if neither of these work for you call the help number, they really are helpful!!!

1 Like


I had similar connection issues when upgrading to the new Wi-Fi 6 mesh network (TP-Link Deco AX3600, aka X68).

Most of my devices connected except for the Ring Pro door bell and 3 Ring cameras.

Customer support was unable to help me get the Ring Pro doorbell online and stated that having special characters in the Wi-Fi password would cause connection issues. Ah man….really???

Yes, the new Wi-Fi password “did” have symbols in it so I removed the symbols, however, this did “not” resolve my issue. I still couldn’t connect to any of the Ring devices. Kept getting same error “Wi-Fi not in range/ not detected” even though device is 5 ft from router.

Went ahead and turned my old network back on and was able to connect all my Ring devices to the old network with no issues.

Performed following for troubleshooting:

  1. Tried using the same name & pw from the old Wi-Fi on the new Wi-Fi, “no change” so not a password issue.
  2. Tried disabling “Fast Roaming” and “Beam Forming”, no change, same issue.
  3. Tried changing the Wi-Fi security type settings, no change, same issue.
  4. Removed security completely so that no password required, still no change.
  5. Tried using the guest network and “finally” was able to connect immediately to all Ring devices. To confirm no issue with symbols/ special characters in my password, I added symbols to the password for the “Guest” Wi-Fi network and still was able to connect all the Ring devices.

So…after all this time trying to resolve this issue, it seems that in my case Ring devices will only connect to the “Guest” Wi-Fi network but not the “Main” Wi-Fi 6 network on the TP-link deco AX3600. For now, I will have to use the “Guest” Wi-Fi network with a password for the 4 Ring devices.

Just wanted to post this information so that anyone else having issues connecting with TP-Link deco or other Wi-Fi 6 mesh networks can first try connecting to the “Guest” side of the network before wasting too much time troubleshooting.

Not sure if issue is on the Ring device or the TP-Link Deco, but there seems to be many posts about incompatibility between Wi-Fi mesh systems and Ring devices.

Turning off Fast roaming resolved this problem with my AX3600. I have to say, Ring support was awful in helping to troubleshoot this. I basically had to test each setting to find the issue. Ring told me to return the camera…which I did and had the same issue until I did the troubleshooting myself.

Hello All, I ran across a problem with my Ring Stick Up Cam in the garage. After working with support I received a replacement. The replacement had the same problem where it would set up ok, but no snapshots and it would time out when trying to go live. I also have the latest eero 6 pro. I remembered the one thing I did change before the problem came up. I switched the eero to PPPOE and set my modem/router to bridge mode. I set the eero back to DHCP and reset the modem back to default and the camera now works!!! I am fine with running the eero in double NAT. Just thought I’d share the issue I had.

Hi Neighbors! I wanted to share that we now have the Ring Alarm Pro with a built in Eero WiFi router. This will work with all ring devices. You can learn more about the Ring Alarm Pro here. Thank you for this feature request!