Doorbell shared but no accept available after clicking email invite link

Doorbell was shared and invite email received in correct email, but after clicking the manage button link in the invite email and logging in to the Ring account website, the accept button nor device was present on the website. Tried logging out and closing the browser (Safari) several times. Tried resending the invite several times. I have successfully accepted previous invite to another doorbell on my mom’s home, and yes, the names of the doorbells are different so there shouldn’t be a conflict there. Any ideas from the community? Everything else seems to be operating fine.

Update: Turns out that the 7 day expiration doesn’t start from the resending of an invite. It only starts again from the original invite. Since it had been over 7 days since the original invite was sent, it didn’t work, even though the invite was resent just minutes before. So to get it to work, the original invite from the owner in their app had to be deleted and a fresh invite sent. This reset the 7 day expiration.

Hi @user6774. Glad to hear your got this sorted!