Doorbell quit after updating app

It has been exactly one year since installing my Ring doorbell. It is connected to power.

I updated the app when prompted and it completely stopped working. I did a reinstall and it worked briefly. I have LOVED it until now.

Now I can not get the rotating light on the doorbell again.

I reinstalled the app, tried again, and boom! Nothing! Is this a frequent occurrence? I keep getting prompted to sign up for my recordings again, that’s how I know it’s been a year but I’m not paying for anything else until I get this Ring Doorbell to work.

I shouldn’t have to replace it in just one year.


Hey @TrudyGrable. Could you reach out to our support team on this concern? They will be able to isolate this further and see what could be causing this to happen. Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19. This has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. Let me know how this goes, as your answer may help other neighbors! :slight_smile: