Doorbell (gen 1) working until changing wifi router

the doorbell was working and the ring app is working with the rest of our alarm devices.
after changing wifi router it can’t connect.
reset the doorbell, went through the setup procedure.

cannot connect to wifi network.

modified settings on router. broadcast ssid. set channel.

reluctant to reinstall app on my iphone since the rest of the ring are working.

changed iphone setting from private address to not private. no change

currently ios 14.2. updating to 14.3 now

only 2.4g radio enabled.

only one ssid. was hidden, now broadcasting

every other device on network connects okay.

I have many hours into this and cannot get past the blinking white light on the right side of the ring.

Hi there, @Hud! It is surprising to hear a reset did not help with this. Even though your Ring app is working for all of your other Ring devices, try performing the setup for this Doorbell using another mobile device entirely, if possible. As you seem experienced with network adjustments, sometimes enabling a standard 2.4 Ghz guest network with basic credentials and encryption can help with initial connection. Although you mentioned the network no longer being hidden, I recommend trying out the “add hidden network” option found on the last step of the in app setup. This option will allow you to manually enter your network information which could help for a smoother initial connection.

If these suggestions did not improve or resolve your concerns, the best next step will be to check in with our support team who will have more advanced solutions after taking a closer look. Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.